Can't Deploy Database for first time - "cannot find the path specified."


  • I am trying to deploy my data base to my server.  I am using SQL Server 2008 Enterprise and the GDR version of DataDude.

    My Server Project deploys just fine, but I get the following messages for my DB project:

    1ScanTrackDatabase1.dbschema(0,0)Error TSD01268: .Net SqlClient Data Provider: Msg 5133, Level 16, State 1, Line 1 Directory lookup for the file "C:\Program Files\Microsoft SQL Server\MSSQL.5\MSSQL\DATA\ScanTrackDev1.mdf" failed with the operating system error 3(The system cannot find the path specified.). 
    2ScanTrackDatabase1.dbschema(0,0)Error TSD01268: .Net SqlClient Data Provider: Msg 1802, Level 16, State 1, Line 1 CREATE DATABASE failed. Some file names listed could not be created. Check related errors. 
    3An error occurred while the batch was being executed. 
    4Done executing task "SqlDeployTask" -- FAILED. 

    I tried to deploy a data base via SSMS and it worked just fine.  I checked the path of  the DB I deployed in SSMS and it matches exactly to the path in the error message.

    Any ideas?  Anyone?

    Thursday, March 12, 2009 5:34 PM


  • I may have this figured out.

    I think I had a hard coded path that was not valid.

    • Marked as answer by Vaccanoll Thursday, March 12, 2009 7:24 PM
    Thursday, March 12, 2009 7:08 PM