none
Route table misconfiguration?

    Question

  • Hey guys,

    I was trying to build OpenVPN with Microsoft Azure but having problems now...

    After adding inbound rules I am able to connect to the server now but something get weird here since I am not able to visit any websites e.g. google.com, amazon.com, etc. Then I searched online and eventually found out that I did not have my route table configured yet. I have tried to configure it myself but failed after many attempts, need some help here.

    I would appreciate it a lot if someone can help my resolve the problem since it is driving me crazy.

    Great thanks!

    Saturday, May 25, 2019 12:35 PM

All replies

  • Can someone just teach me how to configure the route table for OpenVPN please, thanks a lot!
    Saturday, May 25, 2019 2:17 PM
  • Hi Robert, 

    Check the following links, and if the problem continues then post your VNet /  NSG / Route Table configuration, to help you more.


    Please, If you think your question has been answered click "Mark as Answer" if just helped click "Vote as helpful". This can be beneficial to other community members reading this forum thread.

    Saturday, May 25, 2019 6:20 PM
  • Hi Robert,

    Are these issues being experienced on your local machine?  So when you connect your laptop  to the VPN to access the Azure resources, you lose internet on your local machine?

    Just checking I understand fully before responding properly.

    Thanks,

    Matt

    Saturday, May 25, 2019 6:52 PM
  • Hi George,

    Thanks for your help, I have checked the links you gave me a while ago, I think I just need to assign a CIDR range to allow all traffics... Can I or how can I do that? By the way I was using Ubuntu 16.04 as my server to build my VPN and when I try to do the same scripts and configurations with DigitalOcean VPS, it is all fine. The first article was telling me to set the CIDR range to 0.0.0.0/0 to have access to the internet? I am not sure if I am right or not... And I have tried to do so - set the CIDR range to 0.0.0.0/0 but still not working... I might need some help to build my route table. As soon as my account is verified, I will post my route table here. I am not sure if I can express them using words correctly, but I'll have a try:

    I only added one route to the route table - Name: GatewaySubnet; Address Prefix:10.0.3.0/27; Next Hop:Virtual network gateway

    and a subnet: NAME: default; Address range:10.0.0.0/24...

    Please check that for me, Great thanks!

    Sunday, May 26, 2019 2:01 AM
  • Hi Matt,

    Thanks for your reply. As you can see from my reply to George, I am using Ubuntu 16.04 as my server. I am not actually using my VPN to access the Azure resources but just to visit the internet, but as you know, when I have done configuring inbound rules and outbound rules, I connected to it. After connecting I found out that the connection is established but I can not visit any websites at all! So I am asking a question about how to solve it here. Great thanks if you can help!

    Sunday, May 26, 2019 2:07 AM
  • Hi, 

    Can you share the output of 

    $ sudo route -n

    before connecting and post connecting to VPN?

    Regards, 

    Msrini

    Wednesday, May 29, 2019 7:39 AM
    Moderator
  • I've checked the output of that code:

    Destination: [my private ip address]

    gateway: 10.0.0.1

    Genmask: 255.255.255.255

    Flags: UGH

    Metric&Ref&Use: 0

    Iface: eth0

    Appreciated for you reply... Hope that helped to solve the problem...

    Thursday, May 30, 2019 9:40 AM
  • I need the output of your route table info in 2 scenario. When you connect to VPN and when you don't connect t o VPN. So that I can compare and help.

    Regards, 

    Msrini

    Thursday, May 30, 2019 9:58 AM
    Moderator
  • I am not quite sure if there are any misunderstandings... The route table of VM does not change when connecting to it.
    Friday, May 31, 2019 5:03 AM
  • Can you provide more clarity on this issue?

    Is the Source from where you are connecting is in Azure?

    Can you provide network diagram and help me understand what is going wrong?

    Regards, 

    Msrini

    Friday, May 31, 2019 5:13 AM
    Moderator
  • Thanks for your reply.

    I use windows laptop to connect to the VM created in Azure(Ubuntu 16.04). I'm managing to use the OpenVPN to be more secured to visit the internet but do not need access to the source from Azure. Since I am not able to post pictures right now, I posted it on my website and you can have a look.

    http://www.ukgsdn.co.uk/MSDN.html

    Thanks a lot!

    Friday, May 31, 2019 5:45 AM
  • The Route table which you have created is not associated with any subnet. 

    Are you not able to browse websites from your laptop, once connected with OpenVPN?

    Regards, 

    Msrini

    Friday, May 31, 2019 6:06 AM
    Moderator
  • Yeah, this is the case... I have searched google but still not sure how to specify CIDR range for the subnet. Really appreciated!
    Friday, May 31, 2019 6:09 AM
  • Do you want Internet traffic from your laptop to pass via OpenVPN to Azure VM ?

    Is that is what you are trying to achieve?

    Regards, 

    Msrini

    Friday, May 31, 2019 6:22 AM
    Moderator
  • Thanks for your reply.

    Yeah...

    MyLaptop - OpenVPN - Azure VM - Internet

    Friday, May 31, 2019 6:59 AM
  • Alright, then you need to configure NAT in your OpenVPN to get this sorted. 

    From Azure platform perspective,  your VM will be able to reach out to Internet and if you need On-Premises traffic to be forwarded, you need NAT configuration. 

    I would suggest you to contact OpenVPN support to get this sorted out. 

    Regards, 

    Msrini

    Friday, May 31, 2019 9:09 AM
    Moderator