Windows 7 Std embedded Patching issues RRS feed

  • Question

  • HI Guyz,

    I am trying to Install Embeded Security patches on our windows 7 standard embedded machines but I am getting issue of "The Windows Modules Installer must be updated before you can install this package" I am not sure if this is the Issue of ESU Licence if yes then Microsoft mentioned on there article as Windows7 std Support is till Oct2020.Please help me on this issue.



    Tuesday, June 30, 2020 11:40 AM

All replies

  • If memory serves, there was an update to Windows Installer. I am not sure if it will work, but you could enable Windows update on a system, attach it to the internet, and attempt to see if Windows Update pulls down the Windows Installer update.

    Or take a look at this thread:



    Sean Liming - Book Author: Starter Guide Windows 10 IoT Enterprise - www.annabooks.com / www.seanliming.com

    Thursday, July 2, 2020 4:18 PM
  • Thanks for the reply.Yesterday i worked on this and installed the latest SSU Patches, module installer issue has been fixed.But after this when we installed the monthly rollup patch and after rebooted we got bsod and patches got rollback,I am unable to find out the reason yet.If this could be the issue of ESU Licence or hardware compatibility issue.Please suggest.

    • Edited by VivuWS Thursday, July 2, 2020 5:31 PM
    Thursday, July 2, 2020 5:29 PM
  • What was the BSOD number?

    Sean Liming - Book Author: Starter Guide Windows 10 IoT Enterprise - www.annabooks.com / www.seanliming.com

    Friday, July 3, 2020 6:00 PM
  • Here is the bugcheck codes:-The computer has rebooted from a bugcheck.  The bugcheck was: 0x100000d1 (0x00000000, 0x000000ff, 0x00000001, 0x93c06da2).

    I found windows update logs error code0x80070643:

    Installation Failure: Windows failed to install the following update with error 0x80070643:

    Monday, July 6, 2020 9:05 AM
  • The bug check refers to an issue with a USB device: https://support.microsoft.com/en-us/help/2743712/a-windows-7-machine-may-encounter-bugcheck-0x000000d1-while-reading-da#:~:text=A%20Windows%207%20machine%20may%20encounter%20Bugcheck%200x000000D1,in%20your%20device%2C%20but%20Application%20level%20timeouts.%20

    Do you have any USB devices attached to the system?

    Sean Liming - Book Author: Starter Guide Windows 10 IoT Enterprise - www.annabooks.com / www.seanliming.com

    Monday, July 6, 2020 4:51 PM
  • No There is no USB Devices,I see in the windows update logs having error -Online service registration/service ID resolution failedhr etc seems patches checking for Internet or wsus both are not available on the machine even this is workgroup machine.Do you think this can be issue related to this.How we can patch the machine in this scenario.
    Tuesday, July 7, 2020 5:59 AM
  • hi

    have you updated the ESU product key, 0643 errors also relate to an activation failure.

    this article, shows how to


    Tuesday, July 7, 2020 2:07 PM
  • But I see Windows 7 STANDARD Embedded edition have time Till Oct2020.I also tried to install new roll up patches on Embedded OS wind7 std on my lab virtual machine they accepts all new patches without any issue.
    • Edited by VivuWS Wednesday, July 8, 2020 4:22 PM
    Wednesday, July 8, 2020 4:16 PM