locked
MS Chart Datapoints not displayed correctly RRS feed

  • Question

  • User1264858471 posted

    When I run my ASP.Net website in Debug mode my datapoints display correctly on my MS Chart.  When I run my website using 'View in Browser' from VS 2008  immediately after I open my solution the datapoints on my chart display correctly.  But if I 'View in Browser' again, my datapoints do not display on my chart where they should.  Why does this occur?  What is the difference between debug and not using debug?  Something is different.

    I create my datapoints on the chart using:

    risksSeries.Points.AddXY(newImpactPoint, newLikelihoodPoint)

    Wednesday, September 22, 2010 10:11 AM

Answers

  • User1264858471 posted

    I tried  different output formats and got the same results.  The Chart is not resized.

    What I have decided to do is store the value of the datapoints in my database instead of creating the points on the fly.  In some instances I would have duplicate datapoints and I was trying to make the unique by adding a random decimal value to the original xy values. 

    I found that if I create the unique values first and store in the database then use these new values for the xy values on my chart, the datapoints are displayed correctly.

    Thank you for your help and suggestions.  It helped me determine what to do to make my chart work.

     

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Wednesday, September 22, 2010 4:12 PM

All replies

  • User829343672 posted

    is this from  

    System.Web.DataVisualization/

    Wednesday, September 22, 2010 11:49 AM
  • User1264858471 posted

    Im not sure if you are asking me a question?  Or if this is suppose to be the answer to my question? 

    Wednesday, September 22, 2010 12:50 PM
  • User829343672 posted

    Sorry, that was a question (mobile device problems).  What library are you using?

    Wednesday, September 22, 2010 2:36 PM
  • User1264858471 posted

    Yes, it is from System.Web.DataVisualization, Version 3.5.0.0 

    Wednesday, September 22, 2010 2:51 PM
  • User829343672 posted

    Personally I have never had an instance where they are different unless the server or data (obviously) is different.  What exactly are the differences?  The render mode for each browser is the same as far as I can tell (from ChartImg.axd?i=chart_78a8feae00424c888205b3000da696f5_2.png&g=8e4e9b62e8cc46fe848e199db1aa50b8)  Have you tried different output formats?  Is this in a control where the chart is resized somehow?

    Wednesday, September 22, 2010 2:58 PM
  • User1264858471 posted

    I tried  different output formats and got the same results.  The Chart is not resized.

    What I have decided to do is store the value of the datapoints in my database instead of creating the points on the fly.  In some instances I would have duplicate datapoints and I was trying to make the unique by adding a random decimal value to the original xy values. 

    I found that if I create the unique values first and store in the database then use these new values for the xy values on my chart, the datapoints are displayed correctly.

    Thank you for your help and suggestions.  It helped me determine what to do to make my chart work.

     

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Wednesday, September 22, 2010 4:12 PM