locked
Image Control is not working. RRS feed

  • Question

  • User838560247 posted

    Hi,

    I am developing asp.net website. I have copied few images under Bin/Image folder. I have provided static url for imageurl for 1 of images. In the Visual Studio I can see the image getting displayed. However when I run application, in the browser image is not getting displayed. I am using image control from system.web.UI.

    Any pointers would be helpful.

    Sunday, June 5, 2011 9:54 PM

Answers

  • User-267673232 posted

    Hello Abhi.... never your images inside the BIN folder of your application cause that folder always contains DLL of your application if you want to store images of your application then create a separate folder and link your imagebutton imageurl from the folder image....

    regards,

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Sunday, June 5, 2011 10:42 PM

All replies

  • User-267673232 posted

    Hello Abhi.... never your images inside the BIN folder of your application cause that folder always contains DLL of your application if you want to store images of your application then create a separate folder and link your imagebutton imageurl from the folder image....

    regards,

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Sunday, June 5, 2011 10:42 PM
  • User838560247 posted

    Thanks Rick. 

    This just solved my problem. 

    Sunday, June 5, 2011 10:49 PM
  • User838560247 posted

    Thanks Rick,

    Let me ask little bit further--

    I am doing 2 step process

    Step1) accepting image from user by fileupload control and saving this on hard disk.

    Step2) Display the same image using image control.

    Now how can I save images directly into this image folder of the application. currently I am saving images on C: and manually coping them over the images folder of the project directory. Is there any better way?

    Thanks in Advance.

    Sunday, June 5, 2011 10:54 PM
  • Monday, June 6, 2011 1:41 AM