locked
Microsoft Platform Ready Test Tool - SQL Server 2008 R2 Failiure! RRS feed

  • Question

  • I am having issues trying to pass the certification, our product connects and runs code through ASP.NET and we have the SQL Trace to prove everything is connecting and working correctly but for some reason when the test completes it errors out with the following errors:

     TC 1.4   The application should be able to connect successfully.

    Unable To Determine

    TC 1.1   Application should use integrated security in order to connect to SQL Server and SQL Server components or Enable "Enforce password policy" and "Password expiration" for all the SQL Server logins.

    Unable To Determine

       TC 1.2   The logins of the ISV application should not be members of the sysadmin server role

    Unable To Determine

       TC 1.6   All table and index objects of the database(s) used by ISV application should enable ROW Level Compression (recommended And optional).

    Unable To Determine

    Can anyone please help?

    Tuesday, January 18, 2011 7:38 PM

Answers

All replies

  • Hi deFactoGlobal,

     

    It seems that some configuration violate some rules in Microsoft Platform Ready Test Tool. Please modify corresponding configuration to make it obey the rules.

     

    Application should use integrated security in order to connect to SQL Server and SQL Server components or Enable "Enforce password policy" and "Password expiration" for all the SQL Server logins.

    Please make sure Enforce password policy and Password expiration is enabled for all the SQL Server logins. Please connect to SQL Server via SQL Server Management Studio. In Object Explorer, please expand “<Instance> | Security | Logins”. Double-click all the logins using SQL Server authentication to check if Enforce password policy and Enforce password expiration is enabled.

     

    The logins of the ISV application should not be members of the sysadmin server role

    Please make sure the login used by ISV to connect to SQL Server is *not* a member of sysadmin role.

    Please connect to SQL Server via SQL Server Management Studio, and double-click this login. Switch to Server Roles tab and uncheck sysadmin in the right pane.

     

    All table and index objects of the database(s) used by ISV application should enable ROW Level Compression (recommended And optional).

    This modification will increase the CPU pressure. If you are experiencing IO pressure, this option might help improve performance. However it all depends on. I would like to recommend that you do a test in your test environment to see if compression could fulfill the requirement.

     

    Meanwhile the best suggestion is to test it in your test environment. There is no tool could provide perfect suggestion. This tool just provides some comprehensive suggestions. Without any test, it is hard to see if this suggestion is right or the error is proper.

     

    If anything is unclear, please let me know.


    Regards,
    Tom Li
    • Proposed as answer by rinku rimza Wednesday, June 29, 2011 8:07 AM
    Thursday, January 20, 2011 8:26 AM
  • Which exe did you select for testing in the tool since a asp.net application does not have one?


    MH
    Thursday, January 20, 2011 1:54 PM
  • Tom,

    I have tried the above to no avail.

    I changed all users but how do you Enforce Password Policy and Expiration for Windows Logins?

    I changed the user to not be sysadmin but still this got the error.

    As well what about: TC 1.4   The application should be able to connect successfully. ???

    Please let me know, Thanks.

    Friday, January 21, 2011 7:49 PM
  • We selected the .exe file that runs our tool, but the part that interacts with SSAS uses ASP.net in a ASMX/dll file so i believe the tool cannot properly track these changes.
    Friday, January 21, 2011 8:01 PM
  • Hi deFactoGlobal,

     

    Since there is less information about Microsoft Platform Ready Test Tool, I would like to recommend that you also ask it in the following forum:

    http://social.msdn.microsoft.com/Forums/en/perfmon/threads


    Regards,
    Tom Li
    • Marked as answer by Tom Li - MSFT Monday, January 31, 2011 4:53 AM
    Saturday, January 22, 2011 1:17 PM
  • I also had the same problem here is the answer from the test tool MS support...

    .NET based Web Application hosted on the IIS

    1.      Start new test

    2.      Add the hosting process to primary executable

    ·       w3wp.exe - IIS 7.0 & IIS 6.0

    ·       aspnet_wp.exe – IIS 5.0

    3.      Launch the web application and do the database operation

    4.      Complete the test & view the report

    Please Note:

    Ø  All .NET web application runs under w3wp.exe process. So we need to add w3wp.exe to primary executable

    Ø  Make sure only one web application is running and using the database. Because all the .NET web application uses same Process ID

     

    Optimally the test works best if all tiers and the test tool are on the same machine.

    I also got this working by running the site first before starting the test tool. Then selecting svchost.exe then run iisreset and save web.config before opening a browser and start the test. I could see in the log afterwards that tool then added w3wp.exe automatically. Anyway it is thru w3wp.exe you get the ”application making the connection to SQL server”.


    MH
    • Proposed as answer by Mårten Holm Monday, January 24, 2011 10:53 AM
    Monday, January 24, 2011 10:52 AM
  • You can get help for the Platform Ready tests by emailing devspec@microsoft.com
    Monday, January 24, 2011 10:13 PM