none
Default Driver Package Installation Task" failed to complete RRS feed

  • Question

  • Hi,

    Started writing my first KMDF driver for my USB device.  After the initial hiccups , able to connect to my Test PC from the host for debugging.

    But Now I am not able to deploy my USB driver ( usbsample from examples of GITHUB). DefaultDriver package is NOT installed properly.

    See the log below. Please give hints as how to fix this problem.

    ( ONE REMARK:  Once I could get my breakpoint hit properly during debug. While playing around, I created another test driver project with different name and given same VID+PID to it. But I uninstalled the driver afterwards. Could this be a problem? )

    DEV/TEST Setup---->> Test PC: WIN10;HOST PC: WIN7; VS2015 + WDK10

    Using NET for debugging

    Opened WinSock 2.0

    Waiting to reconnect...

    [13:49:43:251]: Remove Existing Remote Package

    [13:49:53:995]: Task "Driver Removal" completed successfully

    [13:49:56:001]: Task "Driver Preparation" completed successfully

    [13:49:56:403]: Default Driver Package Installation Task

    [13:49:56:405]: Removing any existing files from test execution folder.

    [13:49:56:425]: Copying required files for "Default Driver Package Installation Task".

     

    $KitRoot$\Testing\Runtimes\TAEF\te.exe "%SystemDrive%\DriverTest\Run\DefaultDriverPackageInstallationTask.dll" /select:"@Name='Microsoft.DriverKit.DefaultDriverPackageInstallationClass.PerformDefaultDriverPackageInstallation'" /p:"AbsoluteDriverPackagePath=%SystemDrive%\DriverTest\Drivers\usbsamp.inf" /p:"DQ=%SystemDrive%\DriverTest\Drivers\usbsamp.inf" /rebootStateFile:%SystemDrive%\DriverTest\Run\DriverTestReboot.xml /enableWttLogging /wttDeviceString:$LogFile:file="%SystemDrive%\DriverTest\Run\Default_Driver_Package_Installation_Task_00017.wtl",writemode=append,encoding=unicode,nofscache=true,EnableLvl="WexStartTest|WexEndTest|WexXml|WexProperty|WexCreateContext|WexCloseContext|*" /runas:Elevated

    [13:50:06:995]: Result Summary: Total=4, Passed=2, Failed=2, Blocked=0, Warned=0, Skipped=0

    [13:50:07:000]: ERROR: Task "Default Driver Package Installation Task" failed to complete successfully. Look at the logs in the driver test group explorer for more details on the failure.

    [13:50:07:409]: Driver Post Install Actions

    [13:50:07:412]: Removing any existing files from test execution folder.

    [13:50:07:433]: Copying required files for "Driver Post Install Actions".

     

    $KitRoot$\Testing\Runtimes\TAEF\te.exe "%SystemDrive%\DriverTest\Run\DriverTestTasks.dll" /select:"@Name='DriverTestTasks::_DriverPostInstall'" /rebootStateFile:%SystemDrive%\DriverTest\Run\DriverTestReboot.xml /enableWttLogging /wttDeviceString:$LogFile:file="%SystemDrive%\DriverTest\Run\Driver_Post_Install_Actions_00024.wtl",writemode=append,encoding=unicode,nofscache=true,EnableLvl="WexStartTest|WexEndTest|WexXml|WexProperty|WexCreateContext|WexCloseContext|*" /runas:Elevated

    [13:50:09:047]: Result Summary: Total=1, Passed=1, Failed=0, Blocked=0, Warned=0, Skipped=0

    [13:50:09:052]: Task "Driver Post Install Actions" completed successfully

     

    Friday, April 1, 2016 8:53 AM