locked
nodejs on azure with mongodb 32 bit RRS feed

  • Question

  • I tried the nodejs example with mongodb on https://www.windowsazure.com/en-us/develop/nodejs/tutorials/mongodb-database/.

    From what I see, when I run

    Get-AzureMongoDBBinaries

    It downloads 64 bit version of mongodb for Windows. Of course, downloaded version will not working in my 32 bit machine. My question is, in emulator mode, is it possible to work with mongodb 32 bit version? I tried previous tutorial hosted on  www.interoperabilitybridges.com/Azure/Getting_Started_Guide_Node_with_MongoDB.asp and modify script to download mongodb 32 bit, but I always get error :

    [WaWorkerHost.exe] Instance-deployment16(13).tasklistmongo.ReplicaSetRole_IN_2:Unable to connect to server localhost:27019: No connection could be made because the target machine actively refused it 127.0.0.1:27019.

    Thank you.

    Arif


    Tuesday, January 24, 2012 9:53 AM

Answers

All replies

  • Hi,

    I am trying to involve someone familiar with this topic to further look at this issue. There might be some time delay.

    Appreciate your patience.

     

    Best Regards,

    Ming Xu.


    Please mark the replies as answers if they help or unmark if not.
    If you have any feedback about my replies, please contact msdnmg@microsoft.com.
    Microsoft One Code Framework
    Wednesday, January 25, 2012 5:52 AM
  • I now understand the issue. It happened because apparently, azure emulator did not clean created drives to emulate mongodb replica sets. So old lock still exist and new connection failed. I have to delete the lock manually. Hope this is improved in next release.

    However, another error come up.

    [WaWorkerHost.exe] Instance-deployment16(2).tasklistMongo.ReplicaSetRole_IN_0:Command 'cloud' failed: no such cmd: cloud (response: { "errmsg" : "no such cmd: cloud", "bad cmd" : { "cloud" : 1, "nodes" : { "#d0" : "127.255.0.0:27017", "#d1" : "127.255.0.1:27018", "#d2" : "127.255.0.2:27019" }, "me" : "#d0" }, "ok" : 0.0 })

    Thank you,

    Arif

    Thursday, January 26, 2012 8:49 AM
  • This is because you are not using the right version of MongoDB ... You need the version that has been specifically modified for Windows Azure. If you look in the mongo-azure project on GitHub, in the setup script, you will see the URL of the specific version that is installed:  https://github.com/mongodb/mongo-azure/blob/master/ReplicaSets/solutionsetup.ps1
    Thursday, January 26, 2012 9:10 AM
  • As I mentioned in my first post. I'm working with windows 7 32 bit. The available version of modified azure mongodb version is 64 bit. I guess this means I cannot used 32 bit machine to develop nodejs app with mongodb for azure. 
    Thursday, January 26, 2012 10:53 AM
  • Have you tried http://downloads.mongodb.org/win32/mongodb-win32-i386-2.1.1.zip ?
    Thursday, June 21, 2012 11:25 PM