locked
Unfortunately, we couldn't load your app's reviews. Try again later. RRS feed

  • Question

  • More then a week I get this error when I try to see my reviews for one of my app:

    https://dev.windowsphone.com/en-us/ApplicationDetails?productId=[GUID]&applicationDetailsView=2

    error message: "Unfortunately, we couldn't load your app's reviews. Try again later."

    This error is occurs for only one of my app, all the other app reviews are shown correctly, but for this one I get this error over and over again. very anoying!

    I submitted a support ticket, but the support stuff instead of helping saying not related - stupid - things like:
    - "did you have the latest Silverlight version?" - yes I have, but the devcenter review site is no longer silverlight based
    - sending me a link for the most recent "SilverLight" version, but it was actually a one or two years old WCF Ria Services toolkit for Silverlight 4 installer.

    My first guess was that it is a joke, but my second is what the hell is going on in Microsoft?

    Anyone else having this problem?

    • Edited by pubtom Tuesday, November 20, 2012 8:17 PM
    Tuesday, November 20, 2012 12:37 AM

All replies

  • Hi pubtom,

    Can you provide me with the support request number? I'll follow up on this with you.

    Thanks


    Dev Center Help: http://msdn.microsoft.com/library/windowsphone/help --- Submit Support Request: http://go.microsoft.com/fwlink/?LinkId=256412

    Thursday, November 22, 2012 7:36 AM
  • Hi Danny,

    Today the problem seems to be solved.
    The support request number: SRX1188051110ID

    Thanks,
    Tom

    Thursday, November 22, 2012 10:16 PM
  • Hi Danny,

    Unfortunately this problem still not solved!
    Today I get this error message again on my app review site:

    https://dev.windowsphone.com/en-us/ApplicationDetails?productId=[GUID]&applicationDetailsView=2

    "Unfortunately, we couldn't load your app's reviews. Try again later."

    support request number: SRX1188051110ID - Store: Reviews

    Can you please help?

    Thanks,
    Tom


    • Edited by pubtom Wednesday, April 24, 2013 12:58 AM fix
    Saturday, December 15, 2012 10:23 AM
  • Getting this issue for some of my apps as well. Been quite long now, seriously annoying since I can't see how it is faring.
    Wednesday, January 2, 2013 11:41 AM
  • One and a half month and they didn't fix this issue. Come on MS!!

    Wednesday, January 2, 2013 6:26 PM
  • Hi,

    I'm investigating the issue now - I'll update this thread accordingly. Sorry for the delay guys.

    Jin

    Saturday, January 5, 2013 1:11 AM
  • I just wanted to update this thread. We've found the root cause of the problem. We're assesing how often this is occurring which will determine the timeline of the deployment of the fix.

    The issue happens when certain words are translated that causes an error. In the meantime, a workaround is to turn off the auto-translation (pick "<select language>" in the translate dropdown).

    Jin

    • Proposed as answer by SPDoctorMVP Tuesday, January 29, 2013 1:23 PM
    • Unproposed as answer by pubtom Sunday, February 10, 2013 11:37 PM
    Monday, January 7, 2013 11:48 PM
  • Yes, we have been having the same problem and, yes, that workaround works.
    Tuesday, January 29, 2013 1:23 PM
  • Still not fixed ...

    This is a very anoying error.

    Still waiting for the fix ..

    Sunday, February 10, 2013 11:37 PM
  • I suggest to make a bid what will happen earlier: this bug will be fixed or people will land on Mars.
    Monday, February 11, 2013 2:13 AM
  • + people will land on Mars.

    This annoying error message: "Unfortunately, we couldn't load your app's reviews. Try again later." comes again :( on the Dashboard reviews

    Really poor support from MS.

    Monday, October 21, 2013 8:03 PM