Urgent - The application failed to initialize properly - 0xc0000005 RRS feed

  • Question

  • 4 hours ago while working in Visual Studio 2005 with C# something must have happened to the .Net Framework installation.  The last thing I did was deleting a bunch of files from the open solution after which the computer/Visual Studio appeared to work much slower than before. The compiled program did not run anymore instead I just get a dialog box "The application failed to initialize properly - 0xc0000005" which i can only confirm with "OK" and have to do twice to dismiss the close the application.

    Now no .Net program does run anymore, even a fresh ConsoleApplication with an empty Main function crashes the same way. The error dialog comes up even before the console window opens. No other programs seem to be affected, e.g. Visual Studio itself, Office 2003, Acrobat Reader, the Internet Explorer and so on are just running fine, only .Net programs previously working ones and new ones do not work anymore.

    I deinstalled already the .NET SDK 2.0 and the .NET Framework 2.0 and reinstalled them with a restart in between. I even made sure that before reinstalling the deinstallation was successful by checking if the assemblies from the GAC and so on were gone. However, but the problem remains - how can I resolve this problem without spending hours to backup the whole computer and reinstall the whole thing again, that is not really an option...

    Urgent help needed!

    Friday, August 11, 2006 5:34 AM


  • I ran a couple of anti virus programs, spyware detectors and so on and it seems that the one from panda found a Haxdoor virus/backdoor and removed it. After that and a reboot the programs worked again...

    So if anyone experiences that error, be suspicious!

    Friday, August 11, 2006 5:52 PM

All replies

  • look in the event logs for any errors and post them here....


    Friday, August 11, 2006 1:59 PM
  • There are no errors in the event log on my attempts to start .NET programs, just this for each program I try to start (in this cas a fresh Console Application):

    Event Type: Information
    Event Source: Application Popup
    Event Category: None
    Event ID: 26
    Date:  8/10/2006
    Time:  11:23:38 PM
    User:  N/A
    Computer: NOTEBOOK
    Application popup: ConsoleApplication2.exe - Application Error : The application failed to initialize properly (0xc0000005). Click on OK to terminate the application.

    For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.


    Friday, August 11, 2006 3:43 PM
  • sounds like a memory problem to me - these errors can show up because of memory going bad/faulty

    I guess you have tried to uninstall the framework and re-install it.

    ill see what else i can think of

    Friday, August 11, 2006 4:02 PM
  • I ran a couple of anti virus programs, spyware detectors and so on and it seems that the one from panda found a Haxdoor virus/backdoor and removed it. After that and a reboot the programs worked again...

    So if anyone experiences that error, be suspicious!

    Friday, August 11, 2006 5:52 PM
  • Hey John

    Please can u provide me with detailed info as to how u resolved the above issue. I am currently unable to execute any of my visual basic projects due to the above mentioned error. Also, i have already tried uninstalling and reinstalling the program, it still will not work. The only other option i have now is to try what u did so please send me the info asap, i am very desperate!!!




    Friday, October 6, 2006 5:17 AM
  • Well, what finally helped me - I guess not a guaranteed solution, but worth a try - boot up in Safe Mode with Networking, go Panda Software and there the Active Scan (first link in google if you search for these words) and execute the online scan.

    It will take a while, but after it found and removed the virus from my computer everything worked again. I think it might have been that the virus tried to infect my just compiled programs when I tried to run them and by that corrupting them before they executed - but I am not sure of that, just a theory...

    Good luck!

    Friday, October 6, 2006 11:31 PM
  • Hey John,

    I have one more question for u. Can u say whether or not it is it safe to run Panda Antivirus on my system if Norton is already on it. Will i have to uninstall Norton first an then try it. Thanks in Advance

    Saturday, October 7, 2006 6:07 AM
  • well having multiple AV software kind of cancels each other out and can cause undesirable effects. Panda is also known to cause issues with VS and .NET Framework.
    Saturday, October 7, 2006 7:43 AM
  • What I am talking about is just the online scan and during safe mode, so do not explicitly install something the web site will install that tool just for the scan if you do it. And deactive everything else during the scan...
    Saturday, October 7, 2006 3:23 PM
  • in that case yes probably disable the existing AV software you have installed, then do the online scan
    Saturday, October 7, 2006 3:27 PM
  • Thanks all of you,

    I also faced a similar problem just 2 days after you i.e yesterday, and have to say that I benefited from your discussion because after wasting a day over uninstalling and reinstalling .NET and googling all around I was about to format my laptop, when I found this discussion of yours.

    Never really thought some spyware could be present which could stop .NET from compiling.

    This is just for information for everyone, the pandasoftware active scan was giving some problem to me and was not starting on my machine( don't know why), probably some spyware was stopping to start, so I downloaded Lavasoft Ad-Aware and ran it, lavasoft did the same work for me that PandaSoftware did for John, Haxdoor was detected and removed and after the reboot my machine also started working properly.

    Thank you all for this solution.


    Tuesday, October 10, 2006 3:31 PM
  • Hello

    A had same problem. My .net applications didn't run. I checked my system with panda. It found Haxdoor.OC and removed it.

    But it wasn't enought. I checked with Lavasoft Ad-Aware too. It found many problems. It removed them.After restart my applications are working again. :-O

    My theory is: this object was the reason:

    obj[39]=Process : C:\WINDOWS\system32\vistax.dll

    Thanks for your help


    Thursday, December 28, 2006 9:14 AM
  • Hi...


    everytime i log into the user after a few minutes the computer loads up it

    pops up...and so i made another user and its doing the same thing


    well im having the same problem...umm can you help me please

    i dont seem to know what im doing

    Monday, April 23, 2007 12:32 PM

    I have the same problem. When i start fifa or pkr there comes The application failed to initialize properly - 0xc0000005 Could youhelp me? Ihave tried many virus programs but it doesent help.
    Wednesday, April 2, 2008 8:41 PM
  • Check if the following registry value exists on your system:

    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Winlogon
    LeakTrack REGDWORD = 1

    If so, remove it OR set the value to 0.

    It is needed only for debug sessions when memory leaks are to be tracked.
    The value is set by Microsofts UPHClean service for example.

    (posted by NettiCat)

    Wednesday, December 17, 2008 11:40 PM
  • Hello,

    I am also facing this problem while running 3DMAX 9 on my vista machine.
    "the application failed to initialize properly (0xc0000005). Click OK to terminate the application"

    Earlier I had WinXp and this software used to work perfectly. When I upgraded to Vista Ultimate(32Bit), I tred 3DMAX2009(for Vista) but the performance was not good. I uninstalled it and when i Reverted to good ol' 3dMAX-9, it shows this error.

    pls someone help me, i am in dire need to get this up and running ASAP.

    Sunday, June 28, 2009 9:31 AM
  • I have the same problem, can anybody help in this aspect.

    Event Type:    Information
    Event Source:    Application Popup
    Event Category:    None
    Event ID:    26
    Date:        8/27/2009
    Time:        17:42
    User:        N/A
    Computer:    CO
    Application popup: Parsifal.exe - Application Error : The application failed to initialize properly (0xc0000005). Click on OK to terminate the application.

    For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.
    Thursday, August 27, 2009 3:48 PM
  • hi john.doe...

    i have been on the phone with a very helpful ms support rep for ages today going through every process he can think of to help me get rid of these error messages & get my ie8 working !

    he had to give up after awhile as he said it was prob a software problem but not MS XP which i am running ..i installed it twice & also did the repair installation ..nothing stopped these messages described on here ..

    just a quick question as i see the reference to panda antivirus ..

    i am always a little confused by the listings on the google site ..can anyone tell me if there is a free version of panda or any other that actually rids the haxdoor virus from my system & what the website address is i need to go to to perform the scan online in safe mode as you suggested ?

    thank you much..best anne
    Monday, September 7, 2009 2:26 PM
  • Hey All,

    I have the same problem with the new .NET 4.0.30319 framework.

    Most of the FW application give me that error (aspnet_regiis.exe, aspnet_regbrowsers.exe, ...). I tried it with more than one machine (WXP, W2K3) and the same problem.

    Other .NET application running well (ASP.NET v2.x)

    My antivirus is Symantec endPoint 11.0.5002.333. I tried to reinstall the FW while the AV is disabled, and nothing.

    can you please help.

    Sunday, May 2, 2010 11:59 AM
  • Hey,

    I found that Symantec End Point 11.0.5xxx is the problem

    kindly find below links:




    Latest update from Symantec tech support:

    Success! RU6 (11.0.6000.550) finally resolves my issue!

    Monday, July 5, 2010 4:17 PM
  • Hi

    Your solution worked for me. Try fooling others


    Tuesday, September 14, 2010 7:23 AM
  • Hi John,


    I ran into same problem. After a couple of sleepless nights I have tried your solution. It simply worked. Antivirus found few trojans on my PC.


    After that I have my .NET applications started working.


    Thanks for your help.


    Monday, December 12, 2011 2:21 PM