locked
CDN nt working for Azure VM LAMP wordpress site RRS feed

  • Question

  • I was wondering if someone would address  my problems with a VM in azure and azure CDN.

    I have a LAMP based wordpress installation running on an azure VM. its working fine and publically accessible.
    I wanted to try azure CDN - Verizon/Akamai for serving my images.
    I made cdn, using the new resource manager, added my endpoint of filmycurry.com (my origin server). I am using http only, hence configured the same in endpoint.
    my problem is that even  after 12 hours. I still cant access any media using cdn. you may try the below links
    working - vm based - http://filmycurry.com/wp-content/uploads/2016/05/yu-2.jpg

    not working cdn - http://filmycurry.azureedge.net/wp-content/uploads/2016/05/yu-2.jpg

    pls note, I had also configured the path correctly to /wp-content/uploads, since beginning.
    I don't know what to do.
    Requesting your help in the same.
    Thanks.
    b regards
    Saturday, May 21, 2016 5:46 PM

All replies

  • Hi, just wanted to update that its been almost 48 hours. I am still getting 404 error. Can anyone from azure team help me on this pls.

    thanks a lot.

    Monday, May 23, 2016 7:17 AM
  • I am able to successfully access the URL you provide for your CDN endpoint. If you are still seeing issues please provide http server response headers when you make the request to the CDN.
    Monday, May 23, 2016 6:40 PM
  • Hi Anton,

    this started working only after I put a custom name.

    now both custom name and original cdn access url work, surprisingly.

    Didn't know that using custom name was sort of mandatory.

    Thanks.

    Tuesday, May 24, 2016 4:50 AM