none
VS2013pro ignores Linker EntryPoint setting

    Question

  • Hi,

    for some days within a VS2013Pro C++ CLR forms application programming environment I get a 'new' error message (error: LNK1561: entry point must be defined) obviously ignoring, that the entry point of course is set (to 'main' at Configuration Properties | Linker | Advanced | Entry Point).

    I checked 'all options' within the linker's command line summary and compared it to that one of an existing and running project. Found no differences. May be I've been tampering with some other IDE-parameter and don't find them for a reset !?

    Is there a MasterClearButton that resets total VS environment to a new born state?

    Thanks Lino

    Tuesday, June 14, 2016 9:37 AM

Answers

  • Hi Lino_L,

    Thank you for posting in MSDN forum.

    For error: LNK1561, the linker did not find an entry point. You may have intended to link as a DLL,

    in which case you should link with the /DLL option. You may have also forgotten to specify the name of the entry point; link with the /ENTRY option.

    Reference:

    https://msdn.microsoft.com/en-us/library/ky737ya4.aspx

    >>Is there a MasterClearButton that resets total VS environment to a new born state?

    You could reset your VS settings:

    TOOLS->Import and Export Settings Wizard->Reset all settings

    You could also try devenv /resetsettings in Command Prompt.

    Best Regards,


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.

    Click HERE to participate the survey.

    Wednesday, June 15, 2016 2:45 AM
    Moderator