locked
Failed to execute request because the App-Domain could not be created. Error: 0x80131902 RRS feed

  • Question

  • User1401737420 posted

    I installed IIS (whatever comes with XP). 
    I installed the 2.0 .Net framework. 
    I installed SQLServer 2005 Express. 
    I installed Virtual Web Developer Express.

    When I attempted to build my first ASP page, VWD gave me an error saying I was using an older version of ASP.NET, and would I like it to configure my system to 2.0.  I said yes, but it then errored out when it tried to make the change.

    VWD seems to work fine, but when I try to view my page I get the these errors in the event viewer:

    1. "Failed to initialize the AppDomain:/LM/W3SVC/1/ROOT"
    2. "Failed to execute request because the App-Domain could not be created. Error: 0x80131902"

    I found this thread, but honestly don't know how to set permissions on my root folder.  I THOUGHT I did, but either SP2 or perhaps installing IIS has changed how permissions are set.  I'm not even sure this is related.

    Anyway any help is appreciated,  -=STZ=- 

     

    Friday, March 31, 2006 12:53 PM

All replies

  • User-1853252149 posted

    > ...honestly don't know how to set permissions on my root folder.

    Windows Explorer, navifgate to the root folder of the web site (default is c:\inetpub\wwwroot\) and right click that folder.  Choose the security tab, add the IIS_WPG group, check the Modify box for that account.

    This process should also fix your problem:

    http://forums.asp.net/thread/576170.aspx

    Jeff

    Friday, March 31, 2006 3:32 PM
  • User1401737420 posted

    Jeff: Thanks for the reply.  I'm still trying to solve my problem, but I think I figured out a few things. 

    1. SP2 (I'm guessing) switched my system to "Simple Sharing Mode".  I had no "Security" tab.  To get it back you need to you must open Windows Explorer, go to Tools, Folder Options, View and uncheck "Use Simple File Sharing".  Now I have a security Tab.
    2. Next problem is that I don't have a group named IIS_WPG.  It appears that that group is created with IIS 6.x.  I believe I am using IIS 5.1 or whatever comes with XP.  I'm not sure if II6 is a free upgrade or not.

     

    Saturday, April 1, 2006 12:27 AM
  • User-1853252149 posted

    IIS6 is what comes with Server 2003.  In your case it will be the ASPNET account.

    Jeff

    Saturday, April 1, 2006 7:27 AM
  • User1401737420 posted

    That did not solve the problem. 

    Here are the error messages I am getting in the event viewer:

    Failed to initialize the AppDomain:/LM/W3SVC/1/ROOT

    Exception: System.Configuration.ConfigurationErrorsException

    Message: Exception of type 'System.Configuration.ConfigurationErrorsException' was thrown.

    StackTrace: at System.Web.Configuration.ErrorRuntimeConfig.ErrorConfigRecord.System.Configuration.Internal.IInternalConfigRecord.GetLkgSection(String configKey)

    at System.Web.Configuration.RuntimeConfigLKG.GetSectionObject(String sectionName)

    at System.Web.Configuration.RuntimeConfig.GetSection(String sectionName, Type type, ResultsIndex index)

    at System.Web.Configuration.RuntimeConfig.get_HostingEnvironment()

    at System.Web.Hosting.HostingEnvironment.StartMonitoringForIdleTimeout()

    at System.Web.Hosting.HostingEnvironment.Initialize(ApplicationManager appManager, IApplicationHost appHost, IConfigMapPathFactory configMapPathFactory, HostingEnvironmentParameters hostingParameters)

    at System.Web.Hosting.HostingEnvironment.Initialize(ApplicationManager appManager, IApplicationHost appHost, IConfigMapPathFactory configMapPathFactory, HostingEnvironmentParameters hostingParameters)

    at System.Web.Hosting.ApplicationManager.CreateAppDomainWithHostingEnvironment(String appId, IApplicationHost appHost, HostingEnvironmentParameters hostingParameters)

    at System.Web.Hosting.ApplicationManager.CreateAppDomainWithHostingEnvironmentAndReportErrors(String appId, IApplicationHost appHost, HostingEnvironmentParameters hostingParameters)

    For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.

    This is followed by:

    Failed to execute request because the App-Domain could not be created. Error: 0x80131902

    For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.

    I'm going to uninstall SQL Server Express and VWD Express and reinstall...and pray that works.

     

    Sunday, April 2, 2006 12:28 AM
  • User-1053698581 posted
    Make sure you click on the advanced button and replace the permission entries on all child objects.
    Wednesday, April 26, 2006 12:22 AM
  • User-1853252149 posted

    I'm going to uninstall SQL Server Express and VWD Express and reinstall...and pray that works.

    It's a .NET issue, so it likely will have no effect.  Did you try running ASPNET_REGIIS.EXE -i?

    Jeff

    Wednesday, April 26, 2006 7:23 AM
  • User-1542907581 posted

    I have the exact same event with the same problem.  Only, all I'm trying to do is install SQL 2005 with reporting services.  After installation I can not access:

    http://localhost/reporting

    I get an error that states received Text/HTML, expected Text/XML.  This is probably due to the fact that instead of an XML based report page it gets an ASP.NET error page.

    I added IIS_WPG to the root and applied to all child objects.

    I ran "ASPNET_REGIIS.EXE -i".

    I uninstalled SQL 2005 and reinstalled.  Also I installed on a brand new VM domain and got the same exact problem.

    Something seems to be wrong with the Windows Integrated Security.

    Anything else I can try?  My end result is that I want to install forefront but the reporting service must work in order to do that.

    Thanks for all the info thus far.

    Tuesday, May 8, 2007 5:46 PM
  • User-1542907581 posted

    I didn't see an edit option???

     

    I fixed my problem.  For me, IIS was at fault.  I uninstalled everything under application server and then reinstalled all the defaults plus ASP.  Then I had to recreate the virtual folders for the reporting server.

    After that all looks well.

    The only oddity I'm walking away with is that SQL set up a specific application pool for the reporting service and now it's all lumped into the default application pool.  Script and not execute.  I guess I should change it to both since the old one had that setting.

    It would seem SP2 for W2K3 is what hosed my IIS.

    Tuesday, May 8, 2007 8:13 PM
  • User-464668683 posted

    installed IIS (whatever comes with XP). ......I attempted to build my first ASP page, ......  error 

    installed only IIS can host  web page file like  .asp  .aspx  VB script   access SQL office   NO error   WORK!

    Control Panel --> Add or Remove Program --> Add or Remove Windows Components  tick Internet Information service (IIS) 13.5MB

    Copy from i386 folder

    Friday, October 17, 2008 1:21 AM
  • User-464668683 posted

    debug F5   Use IIS Web server  NOT work  in Sol'n Explorer --> My project-->web   error

    Failed to access IIS metabase.

    build... ASP page, ......  error

    if build --> publish   yourApplication     no idea...

    Friday, October 17, 2008 1:22 AM
  • User-1028651214 posted

    Please past your code

    Thursday, November 6, 2008 5:59 AM
  • User-1310972242 posted

     Ok.  Couple things and we'll see if we can't fix your issue.  Note that Jeff is a LOT more knowledgeable about IIS than I, and as such is certainl far more busy.

    That being said:

    1.  You tried to build your first page and VWD said you were using .NET 2.0.   Ok.  You got a solution from somewhere that you tried to build that was 3.0 or 3.5.  I know this because that's the error you got.  That's your first mistake.  If you're a newbie to ASP.NET working off of someone else's solution is generally a bad idea.  Start with an ASP.NET Hello World then go from there.

    2.  Going from 3.5 to 2.0 is generally a bad idea since 3.5 includes AJAX by default, whereas 2.0 does not, among MANY MORE changes.  Going DOWN in frameworks is difficult even for someone to do it by hand.  The "upgrade/downgrade" framework feature (in my opinion) has always been a little shaky in Visual Studio, and the fact that you are doing it in the free version certainly doesn't help matters.

    3.  Failed to initialize AppDomain: ....   This is caused by the ASP.NET worker process (W3SVC) not having appropriate permissions on your machine.  Goto your c:\inetpub\wwwroot\ directory, right click, hit security, add ASPNET to the white block, click FIND NAMES, and it should find the IUSR account on your machine.  Give it read/execute rights.  (You can set write-to rights as needed on a sub directory level).

    4.  The second "failed to execute" is the result of your issue above.  The ASP.NET IUSR account doesn't have permissions. 

    5.  You don't even need to run an ASP.NET web application (in development) in IIS on your local machine.  Use the CTRL + F5 shortcut to build and run the application (without debugging) in the VisualStudio webserver that is based on Cassini.  It's quick, painless, and IT WORKS! 

    6.  Don't let this get you turned off of ASP.NET.  It's a very fine method of development, and I enjoy what I do every day.  IIS is a bit of a bugger to deal with at times, but you get used to the complexity, and as of IIS7 on Server 2k8, it's downright easy to manipulate and work with.  In fact, it's pretty dang speedy on 2k8.

    Hope that helps,
    JP

    Tuesday, April 21, 2009 4:54 PM