The following forum(s) have migrated to Microsoft Q&A (Preview): Azure Active Directory!
Visit Microsoft Q&A (Preview) to post new questions.

Learn More

 locked
Unauthorized error using flow to call API RRS feed

  • Question

  • I am not sure if this is the best forum, or if it is a Flow or Power BI issue.  Long story short is as follows:

    • I have an Azure A2 embedded Power BI capacity
    • I have a Power BI Workspace
    • I am trying to use Flow to assign the workspace to the capacity.
    • I have 1 flow that works on workspace 1 with capacity A
    • I have a second flow that throws an "unauthorized" error when trying to do the same thing with workspace 1 on capacity B
    • I have checked everything 3 times and can't work out what is different - nothing I checked is different (except the GUIDs of course).

    My Config

    • I have an Azure AAD App with Power BI service permissions
    • I have an Azure Security group with the AAD App assigned
    • I have assigned the security group to the capacity Access Control (IAM)
    • I have configured the Power BI tenant settings to allow API control and assigned the Security Group

    My guess is I have missed an authorisation step with my second capacity, but I can't work out what that might be.  Any ideas?


    Self Service BI Expert using Power Pivot http://exceleratorbi.com.au

    Friday, April 5, 2019 7:19 PM

All replies

  • Please check to ensure that the configurations on the permissions of the AAD application are correct. You need to ensure that Dataset.ReadWrite.All is assigned. 

    Also, ensure that you are using an Azure AD Policy that is scoped to the organization or service principal as described in the troubleshooting documentation. https://docs.microsoft.com/en-us/power-bi/developer/embedded-troubleshoot

    enter image description here

    Tuesday, April 16, 2019 11:32 PM
  • If you are still having issues with this, feel free to email your subscription ID to AzCommunity@microsoft.com and I can open a support case for you.

    Most likely it's a permissions or policy issue though.

    Tuesday, April 16, 2019 11:32 PM
  • Please let me know if you were able to get this resolved.
    Thursday, May 2, 2019 11:13 PM
  • Sorry for not responding.  Yes I have been able to resolve this.  The issue was in one of the tenant settings in Power BI

    Self Service BI Expert using Power Pivot http://exceleratorbi.com.au

    Thursday, May 2, 2019 11:18 PM