locked
The tag 'AutoCompleteComboBox' does not exist in XML namespace RRS feed

  • Question

  • Hello,

    I've an issues with an AutoCompleteComboBox control.

    The tag 'AutoCompleteComboBox' does not exist in XML namespace 'clr-namespace:ACBComboBox;assembly=ACBComboBox'.

    I'm at a bit of a loss with this one as it used to work fine. I've not made any changes to the code. I have though moved the whole project to a new folder on my computer. Could that somehow be the source of the issue?

    I've read through a lot of posts on this, and they all relate to missing references. The reference to the ACBComboBox is there though. I've tried deleting it & re-adding it etc. I've tried using intelisense to re-add controls and it predicts the names correctly. 

    I'm at a loss as where to start looking into this one? Any suggestions at all please?

    Thanks!

    Phil.

    Friday, March 14, 2014 9:13 AM

All replies

  • So you see it under the "Reference" folder in your project?  If so, refresh and make sure it's OK.  I've seen where a refresh will change it to show a little exclamation point to indicate something is wrong.

    If that doesn't work, start a new project and try to add the reference and then the control to a form or page and see if it works.

    Mark

    Friday, March 14, 2014 11:58 AM
  • Thanks mark. Yes It's in the references folder, I've refreshed with no errors, and I've tried removing and re-adding it. 

    I've made a small test project, and it shows the same error. I've uploaded that here:

    https://onedrive.live.com/redir?resid=879880045FD56C3A!764&authkey=!AELgfRp67SUfzAg&ithint=folder%2c

    That shows the error I'm getting. Any ideas at all?

    Thanks again,

    Phil.

    Friday, March 14, 2014 1:23 PM
  • Hi Phil,

    I downloaded your project and I could see the error message while debugging the application.

    My question is can you point out for me where you get the dll? Create by yourself or download from Internet somewhere.

    What I understand is it is a autocompletebox and there must be some source for candidate words, I'm afraid you have to set some parameter for it when you initialize the control. Validate it plz.

    --James


    <THE CONTENT IS PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND, WHETHER EXPRESS OR IMPLIED>
    Thanks
    MSDN Community Support

    Please remember to "Mark as Answer" the responses that resolved your issue. It is a common way to recognize those who have helped you, and makes it easier for other visitors to find the resolution later.


    Tuesday, March 18, 2014 9:46 AM
    Moderator
  • Like James said, it may help to know where you obtained the DLL.  

    The SL SDK has an AutoCompleteBox but it appears that you have a control that may be a combination of that and a combobox.

    Mark 

    Tuesday, March 18, 2014 4:07 PM