none
running executable in windows 7 RRS feed

  • Question

  • Hello,

    I've a Console Application that runs exe file, in windows 7, when UAC is on i get access denied  (the file is located in c:\program files...).

    i tried using the "runas" Process.Verb but it still doesn't work.

    any idea how can i accomplish that?

     

    Thanks,

    Gidi.

    Monday, November 15, 2010 9:36 AM

Answers

  • Hi Gidi,

    From my understanding, you have an executable, and you launch the executable from a console application, on Win7, the executable throws an Access Denied exception when attempt to open a file, am I right?

    By the way, you can right click the executable, and select "run as administrator", hope it can helps.


    Sincerely,
    Eric
    MSDN Subscriber Support in Forum
    If you have any feedback of our support, please contact msdnmg@microsoft.com.
    Please remember to mark the replies as answers if they help and unmark them if they provide no help.
    Welcome to the All-In-One Code Framework! If you have any feedback, please tell us.
    • Marked as answer by eryang Tuesday, November 23, 2010 5:26 AM
    Tuesday, November 16, 2010 3:10 AM