locked
Reporting Services Error rsSharePointError Object reference not set to an instance of an object. RRS feed

  • Question

  • I am having problems with SSRS after having worked with a SharePoint Team Member over the phone to recreate the SSP for our SharePoint Server 2007 DEV environment.  We also upgraded to SP 2 in the DEV environment.  When I try to run reporting services web page I get the error message in the subject of this post.  This is the error message I get in the Reporting Services Log File 

    ERROR: Reporting Services error Microsoft.ReportingServices.Diagnostics.Utilities.SharePointException:
    Report Server has encountered a SharePoint error. --->
    System.NullReferenceException: Object reference not set to an instance of an object.
    at Microsoft.ReportingServices.SharePoint.Server.SharePointDBInterface.internalFindObjectsNonRecursive(String wssUrl,
    CatalogItemList& children)
    at Microsoft.ReportingServices.SharePoint.Server.SharePointDBInterface.FindObjectsNonRecursive(String wssUrl,
    CatalogItemList& childList, Security secMgr, IPathTranslator pathTranslator, Boolean appendMyReports) 

    We had to recreate the SSP as the My Sites and Search databases had become corrupt.

    I have tried re-running the Reporting Services Add-In on all servers that have Central Admin on it.  I've also ran grant database access in central admin with no result.  I am still getting the same error message, and none of the reports on the site will run. 

    Does anyone know how to fix this?

    We are running MOSS 2007, and SQL Server 2005.  Our DEV environment is virtual ran in vmware.
    • Moved by Mike Walsh FIN Monday, January 18, 2010 7:44 PM ssrs questions go to SP - BI (From:SharePoint - Setup, Upgrade, Administration and Operation)
    Monday, January 18, 2010 7:35 PM