none
Get-Adgroupmember -recursive misses members, but Get-ADGroupMember works RRS feed

  • Question

  • Recently I was asked to get a list of all users who have domain admin privileges in our domain. We have a some users and an operations group, that are listed as members of the domain admins group. When I run the get-adgroupmember -identity "Domain Admins" -recursive command in powershell, 3 members of the operations group are left out. However, if I run get-adgroupmember -identity "Operations", all members are returned. Operations is a global security group and all members are of the same domain. What would cause something like this to happen?

    Thanks in Advance

    • Moved by Bill_Stewart Monday, March 14, 2016 6:07 PM Abandoned
    Wednesday, December 9, 2015 7:39 PM

All replies

  • If the 3 members of the Operations group that don't show up have the Operations group designated as their "primary" group, then that is a known bug. The issue was reported in PowerShell V 4 on Windows 8.1

    Can you verify the "primary" group of the 3 users, and report your PowerShell version and OS?


    Richard Mueller - MVP Directory Services

    Wednesday, December 9, 2015 8:22 PM