locked
blurred text (kevin delafield ) - 1/25/2006 6:39 PM PST RRS feed

  • Question

  • By: kevin delafield

    in the fabricam demos, as the light source moves from the left hand front to 
    the left hand back, you see this odd blurring and movement of the text in the 
    middle of the screen.
    
    also, some of the widgets within the gui, such as the properties menu have 
    the same affect.  they kind of start of blury and then sharpen, occasionaly 
    moving slightly.
    
    this kind of reminds me of issues i had with win3.1, when trying to use 
    DrawString to write a simple text editor.  well, at least the text moving 
    slightly.
    
    the blur probably has to do with subpixel calculation and some of the font 
    DSP, if i had to guess.
    
    just wondering if these are known issues, and if so, if there is a resolution.
    
    are there similar issues with text rendering in Vista proper?
    
    thanks
    
    Monday, February 18, 2008 9:03 PM

Answers

  • By: Pete(MS)

    Hi Kevin,
    
    We've noted occasional problems with anti-aliasing being delayed. This can 
    cause the issues you note - this is a bug. I'll make sure it gets actively 
    tracked.
    
    Thanks for the useful feedback
    
    Pete Faraday
    Microsoft 
    
    "kevin delafield" wrote:
    
    > in the fabricam demos, as the light source moves from the left hand front to 
    > the left hand back, you see this odd blurring and movement of the text in the 
    > middle of the screen.
    > 
    > also, some of the widgets within the gui, such as the properties menu have 
    > the same affect.  they kind of start of blury and then sharpen, occasionaly 
    > moving slightly.
    > 
    > this kind of reminds me of issues i had with win3.1, when trying to use 
    > DrawString to write a simple text editor.  well, at least the text moving 
    > slightly.
    > 
    > the blur probably has to do with subpixel calculation and some of the font 
    > DSP, if i had to guess.
    > 
    > just wondering if these are known issues, and if so, if there is a resolution.
    > 
    > are there similar issues with text rendering in Vista proper?
    > 
    > thanks
    > 
    Monday, February 18, 2008 11:50 PM

All replies

  • By: Pete(MS)

    Hi Kevin,
    
    We've noted occasional problems with anti-aliasing being delayed. This can 
    cause the issues you note - this is a bug. I'll make sure it gets actively 
    tracked.
    
    Thanks for the useful feedback
    
    Pete Faraday
    Microsoft 
    
    "kevin delafield" wrote:
    
    > in the fabricam demos, as the light source moves from the left hand front to 
    > the left hand back, you see this odd blurring and movement of the text in the 
    > middle of the screen.
    > 
    > also, some of the widgets within the gui, such as the properties menu have 
    > the same affect.  they kind of start of blury and then sharpen, occasionaly 
    > moving slightly.
    > 
    > this kind of reminds me of issues i had with win3.1, when trying to use 
    > DrawString to write a simple text editor.  well, at least the text moving 
    > slightly.
    > 
    > the blur probably has to do with subpixel calculation and some of the font 
    > DSP, if i had to guess.
    > 
    > just wondering if these are known issues, and if so, if there is a resolution.
    > 
    > are there similar issues with text rendering in Vista proper?
    > 
    > thanks
    > 
    Monday, February 18, 2008 11:50 PM
  • By: kevin delafield

    thanks for the response.
    
    actually, though, 1 of the things i noticed was that the characters would 
    kind of twitch left and right, non-uniformly.  so, some would twitch left 
    while others would twitch right.
    
    in any case, i'm sure you're aware of the issues.
    
    thanks
    
    "Pete(MS)" wrote:
    
    > Hi Kevin,
    > 
    > We've noted occasional problems with anti-aliasing being delayed. This can 
    > cause the issues you note - this is a bug. I'll make sure it gets actively 
    > tracked.
    > 
    > Thanks for the useful feedback
    > 
    > Pete Faraday
    > Microsoft 
    > 
    > "kevin delafield" wrote:
    > 
    > > in the fabricam demos, as the light source moves from the left hand front to 
    > > the left hand back, you see this odd blurring and movement of the text in the 
    > > middle of the screen.
    > > 
    > > also, some of the widgets within the gui, such as the properties menu have 
    > > the same affect.  they kind of start of blury and then sharpen, occasionaly 
    > > moving slightly.
    > > 
    > > this kind of reminds me of issues i had with win3.1, when trying to use 
    > > DrawString to write a simple text editor.  well, at least the text moving 
    > > slightly.
    > > 
    > > the blur probably has to do with subpixel calculation and some of the font 
    > > DSP, if i had to guess.
    > > 
    > > just wondering if these are known issues, and if so, if there is a resolution.
    > > 
    > > are there similar issues with text rendering in Vista proper?
    > > 
    > > thanks
    > > 
    Monday, February 18, 2008 11:50 PM