none
FSLogix Corrupted VHD on profile containers RRS feed

  • Question

  • Hello all,

    Since a few weeks we are trying to configure FSLogix profile management for our Citrix XenApp environment. At the moment everything seems to work fine. There is one problem, on the testphase we discovered when a users logs off and on the personal profile settings are not stored on the profile.

    After some investigation we saw at when a user logs in there appears a corrupt_usersSID_username.VHD(X) in the userprofile directory. After a few seconds it dissapears and the user has his own profiledisk witch is totaly new. No personal settings, nothing.

    Is there anyone with the same problem? For other organizations we have configured FSLogix Profile Management and it works fine!

    Thanks in advance, 

    Tuesday, September 24, 2019 10:40 AM

All replies

  • this sounds like an issue best solved via opening a case, and sending the support report 

    Please open a support requst using https://support.fslogix.com/

    here is the information on getting the support tool information. 

    Tuesday, September 24, 2019 6:31 PM
    Moderator
  • @JVK1996 Typically this happens when the original user profile disk was created and does not have an NTUSER.dat file stored within. You will see something like this in the Profile logs... "Creating new user profile disk (user's registry hive was missing)". This is caused when the user logs in and then doesn't log out, but rather the machine resets or something similar. The NTUSER.dat (user registry hive file) was never able to be written back to the container vhd.

    There is also a setting 'DisableRegistryLocalRedirect' that you can read about in this forum post https://social.msdn.microsoft.com/Forums/en-US/11018e7b-7ba5-4a83-bcbe-75d1c1c36a6c/corrupt-profiles-reason-identify that can affect this. Having that set to 1 (the default in July 2019 FSLogix build and later) will cause the registry hive files to created in-place in the users container vhd, rather than having to be copied back into the vhd during the logout.

    Tuesday, September 24, 2019 8:16 PM
    Moderator
  • We had a similar issue, whereby just for some users, they would receive a temporary profile, yet for others it worked fine. The cause of this was that these users (who received the temp profiles) had an RDS profile and home folder path set in their AD account properties (in the RDS tab). Once we removed this from their AD account, it worked fine! 
    Wednesday, September 25, 2019 2:08 PM
  • Awesome!  Thank you, this was exactly my issue, RDS value in AD and a path in the Profile > Profile Path as well.  Both legacy entries that were invalid.  I was pulling my hair out!
    • Edited by TriksterX5 Friday, October 11, 2019 9:45 AM
    Friday, October 11, 2019 9:42 AM
  • We are seeing this issue occur across multiple servers on different domains. Has anyone been able to find a fix for it? 

    The servers are 2016 and 2019 on 2.9.7349.30108, and we have made sure that there are no home folders configured in AD. Also DisableRegistryLocalRedirect is set to 1. 


    Andy Morales (Blog)

    Tuesday, June 16, 2020 1:07 PM
  • Thanks mate. OMG I was looking for a solution for this matter and you are life saver. 
    • Edited by Paranamanna Friday, September 25, 2020 12:19 PM
    Friday, September 25, 2020 12:19 PM