none
Problems with Work Rollup in MSP 2013/2016 RRS feed

  • Question

  • Is it just me or has anyone else had problems with work totals rolling up to resource records in MSP 2013/2016? If I create a project with a single resource and a single one day task and assign one unit of the resource to the task the work value for the task is 8, which it should be. When I look at the work for the resource, it's 0. It remains 0 after an F9 calculation as well. This doesn't happen in MSP 2010. In 2010 the resource work value gets updated after the calculation.

    Can anyone else duplicate this or tell me what's going on? I'm posting the question here because I'm trying to do this in code but the same thing happens when making assignments through the UI.

    Friday, January 29, 2016 5:28 PM

Answers

  • Hi,

    Bill provided test file. Our observations:

    • On client, auto-calculation is turned off due to size of project file
    • With auto-calculation turned off, even with hitting F9 (calculate) nothing changed
    • It worked fine, when turning auto-calculation on and hitting F9

    More observations:
    Not sure, if I need to call it a new feature ..., but from my point of view it is a bug or at least an uexpected change of behavior. With auto-calculation off, hitting F9 calculates work correctly in 2007 and 2010, but nothing happens with 2013 and 2016.

    So I provided a macro with key stroke:

    Sub WorkRollup()
     Application.OptionsCalculation Automatic:=True
     Application.CalculateAll
     Application.OptionsCalculation Automatic:=False
    End Sub

    Regards
    Barbara


    To increase the value of this forum, please mark the replies that helped to solve your issue as answer. If you find answers to questions from other forum participants to be helpful, please mark them as helpful. Your participation will help others to find an appropriate solution faster. Thanks for your support!



    Tuesday, February 2, 2016 5:59 PM
    Moderator

All replies

  • Hi,

    when you "assign one unit", I assume you are using decimal and not Percentage for assignment units?

    I have just tried and it is working fine for me in 2013:

    Regards
    Barbara

    What patch level are you using? I have the following:

    Regards
    Barbara


    To increase the value of this forum, please mark the replies that helped to solve your issue as answer. If you find answers to questions from other forum participants to be helpful, please mark them as helpful. Your participation will help others to find an appropriate solution faster. Thanks for your support!

    Friday, January 29, 2016 6:20 PM
    Moderator
  • Definitely not working here:

    My patch level:

    15.0.4787.1000 32-bit Professional

    • Edited by Bill.B_ Monday, February 1, 2016 7:09 PM
    Monday, February 1, 2016 7:02 PM
  • Hi,

    that's interesting. Are you willing to share you file? Yo can find my email adress on my profile - Website. On my HP (not yet translated :() on page "Kontakt".

    Regards
    Barbara


    To increase the value of this forum, please mark the replies that helped to solve your issue as answer. If you find answers to questions from other forum participants to be helpful, please mark them as helpful. Your participation will help others to find an appropriate solution faster. Thanks for your support!

    Monday, February 1, 2016 7:37 PM
    Moderator
  • Hi,

    Bill provided test file. Our observations:

    • On client, auto-calculation is turned off due to size of project file
    • With auto-calculation turned off, even with hitting F9 (calculate) nothing changed
    • It worked fine, when turning auto-calculation on and hitting F9

    More observations:
    Not sure, if I need to call it a new feature ..., but from my point of view it is a bug or at least an uexpected change of behavior. With auto-calculation off, hitting F9 calculates work correctly in 2007 and 2010, but nothing happens with 2013 and 2016.

    So I provided a macro with key stroke:

    Sub WorkRollup()
     Application.OptionsCalculation Automatic:=True
     Application.CalculateAll
     Application.OptionsCalculation Automatic:=False
    End Sub

    Regards
    Barbara


    To increase the value of this forum, please mark the replies that helped to solve your issue as answer. If you find answers to questions from other forum participants to be helpful, please mark them as helpful. Your participation will help others to find an appropriate solution faster. Thanks for your support!



    Tuesday, February 2, 2016 5:59 PM
    Moderator