locked
Skipped Deploy: Configuration: Debug Any CPU Project not selected to build for this solution conf. RRS feed

  • Question

  • User156231 posted

    I am using Windows 10 Family x64 Visual studio Community 2015 14.0.25.123.00 update 2 Xamarin 4.0.3.214 Xamarin.Android 6.0.3.5

    I am trying to compile and execute with the virtual device XamarinAndroidAPI_15 the solution found there : https://github.com/burf2000/OpenGLXamarin.git

    First I had the following error: "major version 51 is newer than 50, the highest major version supported by this compiler. [javac] It is recommended that the compiler be upgraded." So I uninstalled JDK 6

    Now I have the following error: Skipped Deploy: Project: OpenGLDemo.Droid, Configuration: Debug Any CPU Project not selected to build for this solution configuration

    In my Solution Configuration Properties, Build is checked for OpenGLDemo.Droid for any CPU I tried to delete all folders in obj/ and bin/ I tried to Clean the Project I tried to Unload and Reload the Project.

    I still have the same error... HELP

    Saturday, May 21, 2016 12:57 PM

Answers

  • User156231 posted

    I fixed it, I don't really know how: I changed from Active(Debug) to Debug then I unchecked Build for OpenGLDemo.UITests then from Any CPU to x86, I got a message like "processor mismatch" then back to Any CPU and I could deploy...

    • Marked as answer by Anonymous Thursday, June 3, 2021 12:00 AM
    Saturday, May 21, 2016 2:44 PM

All replies

  • User156231 posted

    I fixed it, I don't really know how: I changed from Active(Debug) to Debug then I unchecked Build for OpenGLDemo.UITests then from Any CPU to x86, I got a message like "processor mismatch" then back to Any CPU and I could deploy...

    • Marked as answer by Anonymous Thursday, June 3, 2021 12:00 AM
    Saturday, May 21, 2016 2:44 PM
  • User241327 posted

    help me deployment issues

    Monday, July 18, 2016 4:11 PM
  • User258859 posted

    Had this same issue and fixed it. Check your configuration manager and make sure that the "Deploy" box is checked for your target platform. The configuration manager can be found by selecting it from the dropdown arrow next to "Debug".

    Tuesday, September 20, 2016 8:18 PM
  • User148199 posted

    @LarryKenobi said: Had this same issue and fixed it. Check your configuration manager and make sure that the "Deploy" box is checked for your target platform. The configuration manager can be found by selecting it from the dropdown arrow next to "Debug".

    That helped me. Thanks for the tip.

    Friday, October 21, 2016 12:09 PM
  • User167919 posted

    Thanks :) this helps

    Wednesday, December 7, 2016 4:38 AM
  • User158703 posted

    @LarryKenobi Thanks! That did trick for me. Started when I opened a "Visual Studio for Mac Xamarin Forms project" in Visual Studio 2015 community...

    Wednesday, December 14, 2016 1:42 PM
  • User274342 posted

    That did for me too. Thank you!

    Monday, January 9, 2017 12:39 AM
  • User302044 posted

    Thanks Larry, worked for me too.

    Wednesday, February 22, 2017 9:42 AM
  • User302158 posted

    @LarryKenobi said: Had this same issue and fixed it. Check your configuration manager and make sure that the "Deploy" box is checked for your target platform. The configuration manager can be found by selecting it from the dropdown arrow next to "Debug".

    Thanks, it helped me

    Tuesday, March 7, 2017 7:34 AM
  • User305728 posted

    Thanks Larry, fixed my problem too! :D

    Tuesday, March 7, 2017 8:54 AM
  • User285901 posted

    Thanks it working :)

    Thursday, March 9, 2017 11:08 AM
  • User317276 posted

    @LarryKenobi said: Had this same issue and fixed it. Check your configuration manager and make sure that the "Deploy" box is checked for your target platform. The configuration manager can be found by selecting it from the dropdown arrow next to "Debug".

    helped to me too , tnx

    Thursday, April 20, 2017 8:12 PM
  • User320617 posted

    @LarryKenobi said: Had this same issue and fixed it. Check your configuration manager and make sure that the "Deploy" box is checked for your target platform. The configuration manager can be found by selecting it from the dropdown arrow next to "Debug".

    This helped me too. Right Click on Project, Select Properties. In the opened dialog box select Configuration Properties & then click Deploy.

    Friday, August 11, 2017 7:55 AM
  • User347278 posted

    @LarryKenobi said: Had this same issue and fixed it. Check your configuration manager and make sure that the "Deploy" box is checked for your target platform. The configuration manager can be found by selecting it from the dropdown arrow next to "Debug".

    This helped for me. Thanks!

    Sunday, October 8, 2017 7:23 PM
  • User354412 posted

    Go to Debug/Configuration Manager the check on Deploy option as bitmap below.

    Wednesday, October 25, 2017 2:30 AM