locked
DataCacheClient name attribute not recognized in web.config RRS feed

  • Question

  • HELP!!!  I am trying to configure Windows Azure Cache (preview) in my web application.  I think I'm close but I can't get passed this web.config error when I run it in Windows Azure compute emulator.  The project builds fine and then opens to the main page with this error:

    [code]

    Line 16:   <!-- Cache exposes two endpoints: one simple and other SSL endpoint. Choose the appropriate endpoint depending on your security needs. -->
    Line 17:   <!--simple-->
    Line 18:   <dataCacheClient deployment="Simple">
    Line 19:     <hosts>
    Line 20:       <host name="CCSMCache.cache.windows.net" cachePort="22233" />

    [/code]

    I copied the configuration settings from my windows azure cache configuration.  Also, the configuration used to say <dataCacheClient name="default">.  I get the same error when I use this setting also.

    Here is part of the web config file: 

    [code]

    <

    configSections>

    <!--

    copied from windows azure cache properties-->

    <

    section name="dataCacheClient" type="Microsoft.ApplicationServer.Caching.DataCacheClientSection, Microsoft.ApplicationServer.Caching.Core, Version=1.0.0.0, Culture=neutral, PublicKeyToken=" allowLocation="true" allowDefinition="Everywhere" />

    <!--

    *****end copy from windows azure cache-->

    <

    sectionGroup name="applicationSettings" type="System.Configuration.ApplicationSettingsGroup, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=">

    <

    section name="MyWebRole.My.MySettings" type="System.Configuration.ClientSettingsSection, System, Version=4.0.0.0, Culture=neutral, PublicKeyToken=" requirePermission="false" />

    </

    sectionGroup>

    <

    section name="dataCacheClients" type="Microsoft.ApplicationServer.Caching.DataCacheClientsSection, Microsoft.ApplicationServer.Caching.Core" allowLocation="true" allowDefinition="Everywhere" />

    </

    configSections>

    <!--

    Cache exposes two endpoints: one simple and other SSL endpoint. Choose the appropriate endpoint depending on your security needs. -->

    <!--

    simple-->

    <

    dataCacheClient deployment="Simple">

    <

    hosts>

    <

    host name="CCSMCache.cache.windows.net" cachePort="22233" />

    </

    hosts>

    <

    securityProperties mode="Message">

    <

    messageSecurity authorizationInfo="YWNzOmh0dHBzOi8vY2NzbWNhY2hlLWNhY2hlLmFjY2Vzc2NvbnRyb2wud2luZG93cy5uZXQvV1JBUHYwLjkvJm93bmVyJmV0RnlvcVZUOGVzSTBlamRXQ3NaMjdBaHF5TzI1SE83UzZESlFQeUdEUmM9Jmh0dHA6Ly9DQ1NNQ2FjaGUuY2FjaGUud2luZG93cy5uZXQ="></messageSecurity>

    </

    securityProperties>

    </

    dataCacheClient>[/code]

    Thursday, June 21, 2012 10:30 PM

Answers

  • It looks like you are trying to convert your application from using windows azure shared caching to windows azure cache (preview). The dataCacheClient section shown is not recognized, can you change the dataCacheClient section to 

    <dataCacheClients>

      <tracing sinkType="DiagnosticSink" traceLevel="Error" />

      <dataCacheClient name="default">

        <autoDiscover isEnabled="true" identifier="[cache cluster role name]" />

        <!--<localCache isEnabled="true" sync="TimeoutBased" objectCount="100000" ttlValue="300" />-->

      </dataCacheClient>

    </dataCacheClients>

    Replace identifier attribute from "[cache cluster role name]" to the actual name of the role that has Caching (Preview) enabled.

    You can follow this link for Migrating from shared cache to caching preview http://msdn.microsoft.com/en-us/library/windowsazure/hh914160

    And refer for proper steps on client side configuration of Azure Caching Preview at http://msdn.microsoft.com/en-us/library/windowsazure/gg278344.


    Friday, June 22, 2012 3:29 AM

All replies

  • It looks like you are trying to convert your application from using windows azure shared caching to windows azure cache (preview). The dataCacheClient section shown is not recognized, can you change the dataCacheClient section to 

    <dataCacheClients>

      <tracing sinkType="DiagnosticSink" traceLevel="Error" />

      <dataCacheClient name="default">

        <autoDiscover isEnabled="true" identifier="[cache cluster role name]" />

        <!--<localCache isEnabled="true" sync="TimeoutBased" objectCount="100000" ttlValue="300" />-->

      </dataCacheClient>

    </dataCacheClients>

    Replace identifier attribute from "[cache cluster role name]" to the actual name of the role that has Caching (Preview) enabled.

    You can follow this link for Migrating from shared cache to caching preview http://msdn.microsoft.com/en-us/library/windowsazure/hh914160

    And refer for proper steps on client side configuration of Azure Caching Preview at http://msdn.microsoft.com/en-us/library/windowsazure/gg278344.


    Friday, June 22, 2012 3:29 AM
  • You've provided the ACS token which will be security breach(other people can use it now without your knowledge). Please delete  and recreate your cache with different name immediately to get a new ACS token.

    Friday, June 22, 2012 11:32 AM