locked
DataSync 2.1 Error Code:8007007e RRS feed

  • Question

  • Hi,

    I am using data sync 2.1 framework for synchronization between SQL Azure and SQL Server Express. i have created a console and a web application for doing so but the sync code is working fine in console application but not in web application. Whenever I try to do sync its gives the following error.

     

     

    “Retrieving the COM class factory for component with CLSID {EC413D66-6221-4EBB-AC55-4900FB321011} failed due to the following error: 8007007e The specified module could not be found. (Exception from HRESULT: 0x8007007E).”

    Tuesday, January 18, 2011 1:17 PM

Answers

  • Hi,

    It seems the application is looking for another version of component. Could you please try to change the Platform target and then try again? Right click the project, click properties, and then switch to Build pane. Another similar thread you can refer to:

    http://social.microsoft.com/Forums/en/syncdevdiscussions/thread/fc139787-7c35-45c3-aaf8-57abba03fc68

    I would also suggest you post the question to the Microsoft Sync Framework Forums, you may get more responses.

     

    Hope this helps,

    Raymond


    Raymond Li - MSFT
    Thursday, January 20, 2011 2:46 AM
  • hi,

    there might be some problem with you dll, some dll is missing try to find the missing one.

    Thursday, January 20, 2011 8:58 AM

All replies

  • Hi,

    It seems the application is looking for another version of component. Could you please try to change the Platform target and then try again? Right click the project, click properties, and then switch to Build pane. Another similar thread you can refer to:

    http://social.microsoft.com/Forums/en/syncdevdiscussions/thread/fc139787-7c35-45c3-aaf8-57abba03fc68

    I would also suggest you post the question to the Microsoft Sync Framework Forums, you may get more responses.

     

    Hope this helps,

    Raymond


    Raymond Li - MSFT
    Thursday, January 20, 2011 2:46 AM
  • hi,

    there might be some problem with you dll, some dll is missing try to find the missing one.

    Thursday, January 20, 2011 8:58 AM