locked
MSTest fails on build server with SP1 (VS2008)

    Question

  • First I discovered the issue during an automated build where my UnitTests didn't run anymore ... I got the following error in the build log file :

    MSBUILD : warning MSB6006: "MSTest.exe" exited with code -2146233082.

    But running mstest directly via the command line on the build server (WinSrv2003 - Team Suite 2008 SP1 - TFS Build 2008 SP1) results in a pop-up window that says :

    MSTest.exe has encountered a problem and needs to close.  We are sorry for the inconvenience.

    Following entries are found in the eventviewer :

    Event Type: Error
    Event Source: .NET Runtime
    Event Category: None
    Event ID: 1023
    Date: 09/15/2009
    Time: 09:53:14
    User: N/A
    Computer: TFSBLDARCHI08
    Description:
    .NET Runtime version 2.0.50727.3053 - Fatal Execution Engine Error (7A035E00) (80131506)

    For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.

    +++++++++++++++++++++++++++++++++++++

    Event Type: Error
    Event Source: .NET Runtime 2.0 Error Reporting
    Event Category: None
    Event ID: 1000
    Date: 09/15/2009
    Time: 09:54:20
    User: N/A
    Computer: TFSBLDARCHI08
    Description:
    Faulting application mstest.exe, version 9.0.30729.1, stamp 488f21a6, faulting module mscorwks.dll, version 2.0.50727.3053, stamp 4889dc18, debug? 0, fault address 0x001c5e00.

    For more information, see Help and Support Center at http://go.microsoft.com/fwlink/events.asp.
    Data:
    0000: 41 00 70 00 70 00 6c 00   A.p.p.l.
    0008: 69 00 63 00 61 00 74 00   i.c.a.t.
    0010: 69 00 6f 00 6e 00 20 00   i.o.n. .
    0018: 46 00 61 00 69 00 6c 00   F.a.i.l.
    0020: 75 00 72 00 65 00 20 00   u.r.e. .
    0028: 20 00 6d 00 73 00 74 00    .m.s.t.
    0030: 65 00 73 00 74 00 2e 00   e.s.t...
    0038: 65 00 78 00 65 00 20 00   e.x.e. .
    0040: 39 00 2e 00 30 00 2e 00   9...0...
    0048: 33 00 30 00 37 00 32 00   3.0.7.2.
    0050: 39 00 2e 00 31 00 20 00   9...1. .
    0058: 34 00 38 00 38 00 66 00   4.8.8.f.
    0060: 32 00 31 00 61 00 36 00   2.1.a.6.
    0068: 20 00 69 00 6e 00 20 00    .i.n. .
    0070: 6d 00 73 00 63 00 6f 00   m.s.c.o.
    0078: 72 00 77 00 6b 00 73 00   r.w.k.s.
    0080: 2e 00 64 00 6c 00 6c 00   ..d.l.l.
    0088: 20 00 32 00 2e 00 30 00    .2...0.
    0090: 2e 00 35 00 30 00 37 00   ..5.0.7.
    0098: 32 00 37 00 2e 00 33 00   2.7...3.
    00a0: 30 00 35 00 33 00 20 00   0.5.3. .
    00a8: 34 00 38 00 38 00 39 00   4.8.8.9.
    00b0: 64 00 63 00 31 00 38 00   d.c.1.8.
    00b8: 20 00 66 00 44 00 65 00    .f.D.e.
    00c0: 62 00 75 00 67 00 20 00   b.u.g. .
    00c8: 30 00 20 00 61 00 74 00   0. .a.t.
    00d0: 20 00 6f 00 66 00 66 00    .o.f.f.
    00d8: 73 00 65 00 74 00 20 00   s.e.t. .
    00e0: 30 00 30 00 31 00 63 00   0.0.1.c.
    00e8: 35 00 65 00 30 00 30 00   5.e.0.0.
    00f0: 0d 00 0a 00               ....    

    +++++++++++++++++++++++++++++++++++++++++++++++
     
    Before the installation of TFS2008 SP1 and VS2008 SP1 all worked fine. Locally on my development pc, running mstest via the command line on the same testcontainer works without any problems ...

    Any ideas what could be wrong here? Searching on the web with error code -2146233082 didn't give me any results ...

    Best regards,

    Pieter Gheysens.
    Tuesday, September 15, 2009 7:58 AM

Answers

All replies