WCF service methods can't be executed RRS feed

  • Question

  • User1382949179 posted

    I have a the most bizarre problem.  I have a WCF service that works in my Dev enviroment but not in my QA environement.  Well, it actually does work in QA for another app but mine doesn't and I'm not getting any errors logged anywhere.  I have the same service configs in my web.config that the other app does and I even installed my app on the server that hosts the app that's working.  I was getting the following error:

    The communication object, System.ServiceModel.ChannelFactory`1[T], cannot be used for communication because it is in the Faulted state.

    but after reading some posts about not putting the WCF client in a using statement I'm no longer getting any errors logged.   The IIS logs on the server hosting the service show no requests being made to the service.  This makes sense since that error is with the client but the client is not actually logging any errors now.  I have WCF tracing turned on and still nothing shows on the client or the server.  I"m pretty baffled as I've been googling for three days and tried so many things I can't even count them.  Nothing seems to work (except the other app, and yes I've tried using SoapUI from the web server to see if I can access the service but with similar failed results).  

    Any, and I mean ANY, help will be truely appreciated.

    Friday, September 13, 2013 10:15 PM


All replies