none
System.Net.Http.HttpRequestException: IPv4 address 0.0.0.0 and IPv6 address ::0 are unspecified addresses that cannot be used as a target address RRS feed

  • Question

  • Hi,

    I'm using a core .net 2.2.104 (server) application that listen on given ports.

    However, I cannot get the application to listen on any ip addresses given by the 0.0.0.0 designation:

    managementUri='http://0.0.0.0:15580/'
    workloadUri='http://0.0.0.0:15581/'
    iothubHostname='xxxxxxxxxx'
    deviceId='iotedgedev-edgedevice'
    moduleId='xxxxxxx'
    moduleGenerationId='xxxxxxxx'
    apiVersion='2018-06-28'
    2019-03-24 12:00:05.973 +00:00 [INF] - Using the Management API via http://0.0.0.0:15580/
    2019-03-24 12:00:05.973 +00:00 [INF] - Using the Workload API via http://0.0.0.0:15581/
    2019-03-24 12:00:06.081 +00:00 [INF] - Started operation refresh twin config
    2019-03-24 12:00:06.134 +00:00 [INF] - Edge agent attempting to connect to IoT Hub via Amqp_Tcp_Only...
    2019-03-24 12:00:06.291 +00:00 [INF] - Using in-memory store
    2019-03-24 12:00:06.364 +00:00 [FTL] - Fatal error starting xxxxx.
    System.Net.Http.HttpRequestException: IPv4 address 0.0.0.0 and IPv6 address ::0 are unspecified addresses that cannot be used as a target address.
    Parameter name: hostName ---> System.ArgumentException: IPv4 address 0.0.0.0 and IPv6 address ::0 are unspecified addresses that cannot be used as a target address.
    Parameter name: hostName ...

    What am I doing wrong?

    Thank you.

    /Henrik Bach





    • Edited by HenrikBach1 Sunday, March 24, 2019 12:33 PM clarity
    Sunday, March 24, 2019 12:26 PM

Answers

  • Hi,

    Thank you for answering my issue.

    However, it turns out that what I'm trying to do, is not valid according this thread (which I found after having issued this issue):

    https://github.com/dotnet/corefx/issues/32971

    Thank you for your help.

    /Henrik

    • Marked as answer by HenrikBach1 Monday, March 25, 2019 5:19 AM
    Monday, March 25, 2019 5:19 AM

All replies

  • Hi HenrikBach1,

    Thank you for posting here.

    For your question, there are many possibilities could cause the error. Could you provide more details?

    1. Could you input your code with the red icon below to let me check the format of the URL?

    2. Could you provide the code about which line thrown the exception?

    3. If it is possible, could you provide a code sample which could reproduce the error for me to test?

    Best Regards,

    Wendy


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Sunday, March 24, 2019 3:06 PM
    Moderator
  • Hi,

    Thank you for answering my issue.

    However, it turns out that what I'm trying to do, is not valid according this thread (which I found after having issued this issue):

    https://github.com/dotnet/corefx/issues/32971

    Thank you for your help.

    /Henrik

    • Marked as answer by HenrikBach1 Monday, March 25, 2019 5:19 AM
    Monday, March 25, 2019 5:19 AM