locked
DEP0700 : Registration of the app failed. error 0x8007064A

    Question

  • Getting this error when trying to deploy my app from Visual Studio:

    Error : DEP0700 : Registration of the app failed. error 0x8007064A: Cannot register the MyApp.App_1.7.0.2_neutral__see423jdtcv3y package because the following error was encountered while initializing the windows.repositoryExtension extension: The configuration data for this product is corrupt. Contact your support personnel. (0x80073cf6)  

    It started when I deleted the App folder from C:\Users\MyAccount\AppData\Local\Packages folder when investigating some caching issues.

    This is an app already in Store, so I cannot change the Package Name (and I wouldn't like that workaround in the first place, either). I did try changing the Package Name, just for the kicks, but get error: "The Name attribute of the Identity element in the app manifest must have the Package name value of the selected app: 'MyApp.App'. (FYI: Have changed my app name in the error messages)

    I have logged off, restarted Visual Studio, restarted computer, tried to reinstall the app from Store (which doesn't work by the way, giving the same error code 0x8007064A). I've also uninstalled the app from Simulator. There are no other users on the machine who have the app installed, in fact, there is only one local user.

    Any thoughts?

    Wednesday, October 31, 2012 6:39 AM