Distributed COM Error Message RRS feed

  • Question

  • I have been getting this error message on my MOSS 2007 server after configuring MOSS on Windows Server 2008 R2.  I have no idea what the error message means nor a way to solve it or if it can even be attributed to my MOSS installation or some other factor.

    The application-specific permission settings do not grant Local Activation permission for the COM Server application with CLSID
     and APPID
     to the user NT AUTHORITY\NETWORK SERVICE SID (S-1-5-20) from address LocalHost (Using LRPC). This security permission can be modified using the Component Services administrative tool.

    Please advise.

    Sunday, April 4, 2010 3:15 AM


All replies

  • Hi VS2010,

    beside talhak provided, The solution for this DCOM error is to grant the affected user permissions to start the COM component.

    so plz, follow these steps:-

    follow these steps:

    1. Go to Start – Run, and type regedit, and press enter
    2. Locate and then click the following registry subkey:
      Note In this subkey, “CLSID value” is a placeholder for the CLSID information that appears in the event error. I.e. in case of Sharepoint, the CLSID would be {61738644-F196-11D0-9953-00C04FD919C1},
    3. Double-click on AppID in the right pane, .
      A dialog box appears. Leave this box open
    4. Go to Start – Run, and type dcomcnfg, and press enter
    5. In the Component Services window, go to Component Services, go to Computers, go to My Computer, and then click DCOM Config.
    6. In the details pane, locate the program by using the friendly name, then choose Properties by right clicking on it
    7. At the Security tab, in the Launch and Activation Permissions area, click Customize, and then click the Edit button.
    8. Add the Local Service or Network Service account by clicking the Add button, typing the user’s account name (Local Service or Network Service, this depends on whats in your event error), and then clicking OK.
    9. Select the account name you just added, click to select the Allow check boxes for the following items:
      • Local Launch
      • Remote Launch
      • Local Activation
      • Remote Activation
    10. Click OK two times and quit the registry editor


    Best Regrads, Ahmed Madany
    Sunday, April 4, 2010 11:47 AM
  • I am using Windows Server 2008 R2 and when I go into DCOMCNFG and select the Security tab, all of the radio buttons are grayed out for me.  Is there a way to enable these radio buttons so that I can perform the required steps?


    Monday, April 5, 2010 3:08 PM
  • Hi VS2010,

    check the following , hope this help you


    Best Regrads, Ahmed Madany
    • Marked as answer by GuYuming Friday, April 16, 2010 8:19 AM
    Wednesday, April 7, 2010 10:16 AM