none
Cannot find or open the PDB file RRS feed

  • Question

  • Hi

    I'm trying to debug a Word 2016 add-in with Visual Studio 2017 community edition. I can't get too far without the PDB files but none of the ones for Office can be loaded. 

    Original location is listed as f:\office\target\x86\ship\x-none\xxxx.pdb - I'm guessing that was a temp file used by Office setup as it no longer exists (Office is installed from a Office 365 ProPlus subscription).

    Would uninstalling then reinstalling locally fix things or is there another way to obtain the PDBs? I have Microsoft Symbol Servers enabled but obviously that isn't a source for Office files.

    Thanks

    Friday, May 18, 2018 4:40 PM

Answers

  • I've found the problem. Shouldn't have had Properties > debug > Enable native code debugging checked...
    • Marked as answer by jamesp1 Friday, May 18, 2018 5:46 PM
    Friday, May 18, 2018 5:46 PM

All replies

  • I haven't ever seen symbol files for Microsoft Office applications being made available for public use.

    Are you simply assuming that Microsoft makes them available?

    Friday, May 18, 2018 4:50 PM
  • Hello James,

    Microsoft Office doesn't provide PDB files for developers.

    Why do you need to use them? Do you get any exception or errors in the code?


    profile for Eugene Astafiev at Stack Overflow, Q&A for professional and enthusiast programmers

    Friday, May 18, 2018 5:01 PM
  • Not errors but I can't step through code - keeps popping up with "no symbols loaded" whenever it hits a range object.
    Friday, May 18, 2018 5:28 PM
  • James,

    Looks like you simply need to change VS settings to disable debugging unmanaged code. 

    Most probably, you will also have to disable mixed-mode debugging. See Project + Properties, Debug tab, "Enable unmanaged code debugging" checkbox.


    profile for Eugene Astafiev at Stack Overflow, Q&A for professional and enthusiast programmers


    Friday, May 18, 2018 5:34 PM
  • I've found the problem. Shouldn't have had Properties > debug > Enable native code debugging checked...
    • Marked as answer by jamesp1 Friday, May 18, 2018 5:46 PM
    Friday, May 18, 2018 5:46 PM