none
Microsoft .NET Framework 4 is already a part of this operating system. You do not need to install the .NET Framework 4 redistributable. RRS feed

  • General discussion

  • Hi, 

    I'm trying to install Trados (translation software) and it cannot install and is giving me this error message:

    Component Microsoft .NET Framework 4.5.2 (x86 and x64) has failed to install with the following error message:
    "A failure occurred attempting to install the Microsoft .NET Framework 4.5.2."

    The following components failed to install:

    - Microsoft .NET Framework 4.5.2 (x86 and x64)"

    I have tried installing .NET Framework from the microsoft website and it gives me this error message:

    "Microsoft .NET Framework 4 is already a part of this operating system.  You do not need to install the .NET Framework 4 redistributable."

    Same or higher version of .NET Framework 4 has already been installed on this computer."

    I have tried going on TURN WINDOWS FEATURES ON OR OFF but when I go there, there is no .NET Framework 4 and I have checked all subfolders and nothing.

    Here are the answers to your questions and here are my logs:

    http://www.filedropper.com/vslogs

    1. Version of .NET Framework you are trying to install: the latest, would be .NET Framework 4
    2. Where did you get it (web page, path, application that redistributed the framework): I didn't install anything
    3. Is this a pre-release, CTP or beta version? Which? (Beta#, CTP (Month Year), RC, etc): I don't know
    4. What .NET Framework Patches do you currently have installed? : don't know

    Thanks in advance for your help !

    Adeline

    Sunday, January 31, 2016 8:06 PM

All replies

  • Your install logs indicate that your OS is "OS Version = 6.2.9200, SP = 0.0, Platform 2 OS Description = Future OS - x64"  Is this Windows Server 2012? If not, what is it?

    Also, please use this tool to identify the .NET versions currently installed on your system:

    http://blogs.msdn.com/b/astebner/archive/2008/10/13/8999004.aspx

    Run the tool with the highest available .NET version selected, then post the first 25 lines of the tool log here.

    Once we ID your Windows version and installed .NET Frameworks, we can better address your software installation issue.

    Sunday, January 31, 2016 11:23 PM
  • Thanks for your prompt reply. I was so stressed out about this and completely forgot to tell you:

    I have Windows 8

    I ran the tool with the highest available .NET version and I guess I had to click on "view log" afterwards to get the 25 first lines? Let me know if that's not what you're looking for and if so please tell me where to find the tool log:

    ======================================================================
    [02/01/16,01:58:16] Beginning of new SetupVerifier activity logging session
    [02/01/16,01:58:16] Build created on December 18, 2015
    [02/01/16,01:58:16] For more information about repairing the .NET Framework, see http://support.microsoft.com/kb/2698555 and http://go.microsoft.com/fwlink/?LinkID=246062
    [02/01/16,01:58:16] Activity log file location: C:\Users\adeline\AppData\Local\Temp\setupverifier_main_02-01-16_01.58.16.txt
    [02/01/16,01:58:16] Error log file location: C:\Users\adeline\AppData\Local\Temp\setupverifier_errors_02-01-16_01.58.16.txt
    [02/01/16,01:58:16] Detected operating system: Windows 8 (x64)
    [02/01/16,01:58:16] Windows directory: C:\Windows
    [02/01/16,01:58:16] System directory: C:\Windows\system32
    [02/01/16,01:58:16] Program Files directory: C:\Program Files (x86)
    [02/01/16,01:58:16] Common Files directory: C:\Program Files (x86)\Common Files
    [02/01/16,01:58:16] Install state for .NET Framework 1.0: not installed.
    [02/01/16,01:58:16] Install state for .NET Framework 1.1: not installed.
    [02/01/16,01:58:16] Install state for .NET Framework 2.0: installed with service pack 2.
    [02/01/16,01:58:16] Install state for .NET Framework 3.0: installed with service pack 2.
    [02/01/16,01:58:16] Install state for .NET Framework 3.5: installed with service pack 1.
    [02/01/16,01:58:16] Install state for .NET Framework 4 Client: installed with no service packs.
    [02/01/16,01:58:16] Install state for .NET Framework 4 Full: installed with no service packs.
    [02/01/16,01:58:16] Install state for .NET Framework 4.5: installed with no service packs.
    [02/01/16,01:58:16] Install state for .NET Framework 4.5.1: not installed.
    [02/01/16,01:58:16] Install state for .NET Framework 4.5.2: not installed.
    [02/01/16,01:58:16] Install state for .NET Framework 4.6: not installed.
    [02/01/16,01:58:16] Install state for .NET Framework 4.6.1: not installed.
    [02/01/16,01:58:16] Not adding product '.NET Framework 1.0' because it is not currently installed
    [02/01/16,01:58:16] Not adding product '.NET Framework 1.1' because it is not currently installed
    [02/01/16,01:58:16] Not adding product '.NET Framework 1.1 SP1' because it is not currently installed
    [02/01/16,01:58:16] Not adding product '.NET Framework 2.0' because it is not currently installed
    [02/01/16,01:58:16] Not adding product '.NET Framework 2.0 SP1' because it is not currently installed
    [02/01/16,01:58:16] Not adding product '.NET Framework 3.0' because it is not currently installed
    [02/01/16,01:58:16] Not adding product '.NET Framework 3.0 SP1' because it is not currently installed
    [02/01/16,01:58:16] Not adding product '.NET Framework 3.5' because it is not currently installed
    [02/01/16,01:58:16] Not adding product '.NET Framework 4.5.1' because it is not currently installed
    [02/01/16,01:58:16] Not adding product '.NET Framework 4.5.2' because it is not currently installed
    [02/01/16,01:58:16] Not adding product '.NET Framework 4.6' because it is not currently installed
    [02/01/16,01:58:16] Not adding product '.NET Framework 4.6.1' because it is not currently installed
    [02/01/16,01:58:47] Starting verification for product .NET Framework 4.5
    [02/01/16,01:58:47] Section [Files - .NET Framework 4 Client (Common)] - start parsing entries


    Monday, February 1, 2016 1:14 AM
  • OK, now we know that you have all the embedded .NET Frameworks for your Windows 8 (versions 2.0 through 4.5).

    So, if you tried to install .NET 4.0, the message you got:

    "Microsoft .NET Framework 4 is already a part of this operating system.  You do not need to install the .NET Framework 4 redistributable."

    is appropriate and correct.

    Please try this procedure:

    1. Clear out your %temp% folder of all past install logs etc. FYI, the %temp% folder can be found by simply searching for it from your system search prompt. It is safe to delete everything in the %temp% folder.

    2. Make sure all your anti-virus and anti-malware software is disabled.

    3. Download the .NET 4.5.2 offline installer:

    https://www.microsoft.com/en-us/download/details.aspx?id=42642

    4. Make sure you are signed onto your system as a user with administrative privileges, then run the installer As Administrator.

    5. If the install fails, please provide a new vslogs.zip, as you did previously.


    Monday, February 1, 2016 3:06 PM
  • Hi, 

    Thanks. I followed all your instructions.

    This time the installation process started (before it didn't) but at the very end of the installation it says:

    "Installation did not succeed. 

    .NET Framework 4.5.2 has not been installed because no such interface supported"

    Here is the new vslogs.zip:

    http://www.filedropper.com/vslogs_1

    I hope we can fix this

    Thanks in advance !

    Monday, February 1, 2016 5:54 PM
  • OK, I found this message:

    "PerformOperation on exe returned exit code 2147500034 (translates to HRESULT = 0x80004002)"

    Please read and follow item 5 in this article:

    http://blogs.msdn.com/b/varungupta/archive/2010/12/10/10028352.aspx

    Tuesday, February 2, 2016 1:48 AM
  • OK i followed everything from item 5 in the article and nothing works.

    I tried the first option and it still gave me the same error message and then I tried to download the latest version of Windows Update Agent and it gave me this error message:

    Installer encountered an error: 0x80004002 No such interface supported

    I had installed Trados 2 years ago and it worked fine so I don't know why it's doing that... I guess maybe I should try and buy a new computer ?

    Or do you think this link here could be helpful ?

    https://social.msdn.microsoft.com/Forums/vstudio/en-US/bae7178a-f6b0-4219-b2a4-8f3af366a7a6/net-error-no-such-interface-supported?forum=netfxsetup

    what do you think ?

    Tuesday, February 2, 2016 12:17 PM
  • Or do you think this link here could be helpful ?

    https://social.msdn.microsoft.com/Forums/vstudio/en-US/bae7178a-f6b0-4219-b2a4-8f3af366a7a6/net-error-no-such-interface-supported?forum=netfxsetup

    what do you think ?

    Yes, I would try the procedures mentioned in the thread you cited. I hope it helps.
    Tuesday, February 2, 2016 2:41 PM