none
Find-ContainerImage fails in Nano Server TP5 running as a Hyper-V virtual machine RRS feed

  • Question

  • I've followed the instructions in Install OS images  in the Windows Containers documentation for Nano Server, but having installed the ContainerImage package provider (apparently successfully), the Find-ContainerImage command fails thus:

    [NanoDataCenter]: PS C:\> Find-ContainerImage WARNING: Cannot bind argument to parameter 'fastPackageReference' because it is an empty string. WARNING: The property 'version' cannot be found on this object. Verify that the property exists. WARNING: The property 'Name' cannot be found on this object. Verify that the property exists. WARNING: Cannot find path 'C:\Users\administrator\AppData\Local\ContainerImage\ContainerImageGallery_ContainerImageSearchIndex.txt' because it does not exist. WARNING: Cannot find drive. A drive with the name 'CleanUp' does not exist. WARNING: Save-HTTPItem: Bits Transfer failed. Job State: ExitCode = -2147023651

    Likewise, the Install-ContainerImage -Name NanoServer command fails.

    Note that I'm running Nano Server TP5 itself in a Hyper-V VM hosted by Windows 10 Pro Insider Preview build 14342

    Can anyone confirm whether this is a problem specific to me?

    Thanks,

    Dan


    Dan

    Wednesday, May 18, 2016 11:29 AM

All replies

  • I've worked around this problem. What I've ended up doing is the following:

    1) Install the ContainerImage package provider on the Windows 10 host machine.

    2) Use the ContainerImage package provider on the Windows 10 host machine to download the Nano Server .wim file using the Save-ContainerImage command.

    3) Copy the downloaded .wim file (NanoServer-10-0-14300-1010.wim in this case) from the Windows 10 host to the Nano Server guest VM.

    4) Use the Install-ContainerHost.ps1 script on the Nano Server guest VM (as described in the configure a container host documentation) with the -PSDirect and -WimPath arguments thus:

    .\Install-ContainerHost.ps1 -PSDirect -WimPath C:\wim_files\NanoServer-10-0-14300-1010.wim
    After going through the above procedure, the docker images command showed the nanoserver image installed.


    Dan

    Thursday, May 19, 2016 9:23 AM