locked
classic asp on iis 7 windows vista ultimate- help please!!!!!!! RRS feed

  • Question

  • User118256015 posted

    hello.

    i build up some sites on the xp pro iis. and i just upgraded to windows vista with iis 7,

    in the stat i hade a problem openning the local host but that i manneged to fix. and now all of my HTML pages are working. but my asp pages don't load. and i have this page:

     

    <!-- Error title --> <!-- This row is for HTTP status code, as well as the divider--> <!-- Error Body --> <!-- What you can do --> <!-- refresh page --> <!-- back to previous page --> <!-- InfoBlock -->
    Info icon

    The website cannot display the page

    <ID id=http500> HTTP 500</ID>
     

    Most likely causes:

    • The website is under maintenance.
    • The website has a programming error.
     

    What you can try:

     

    Refresh the page.<NOSCRIPT id=refreshPage></NOSCRIPT>

     

    Go back to the previous page.<NOSCRIPT id=goBack></NOSCRIPT>

     

    More information More information<NOSCRIPT></NOSCRIPT>

     

    now pleaseee help me! i need to hand it in next week.

    p.s

    my web is only simple asp and html. and accesse data base.

    thnks.

    daniel

    Wednesday, February 7, 2007 11:02 AM

All replies

  • User1356161706 posted

    Reisel,

     Are all ASP pages broken or just the ones that access the Access database?

    Can you try if this simple ASP script works (should show the current time)?

    <%=Now%>

    If only the Access ASP pages are broken try the following command:

    %windir%\system32\inetsrv\appcmd set config -section:system.applicationHost/applicationPools -applicationPoolDefaults.processModel.loadUserprofile:false

    Hope this helps.

    Thursday, February 8, 2007 8:19 PM
  • User118256015 posted

    dude!!

    you rock!!

    thnx .. all good now:)

    Friday, February 9, 2007 10:57 AM
  • User118256015 posted

    okay now every thiong works.

    but if i got an error the explorer 7 doesn't show me the error or the line like the old explorer did// do you know how to fix this problem?

    thnx man:)

    Friday, February 9, 2007 6:55 PM
  • User-2026410440 posted

    Hi Reisel -

    This is a default setting change in IIS7 to keep debug information more secure.  You can enable ASP debug information in the Inetmgr admin tool by browsing to the "ASP" feature and changing the "Send Errors To Browser" setting to "true".  (you can find that setting by expanding compilation, and then expanding debugging properties).

    Here is an image to help out:

    Click here for a full size image. 

    You can also set this globally, on the cmd-line, by running the following command:

    \Windows\System32\inetsrv>appcmd set config -section:asp -scriptErrorSentToBrowser:true

    good luck!

    Friday, February 9, 2007 7:07 PM
  • User118256015 posted

    tnx for the comment,

    but i cant see the error/ only the regular:

    <!-- This row is for HTTP status code, as well as the divider--> <!-- Error Body --> <!-- What you can do --> <!-- refresh page --> <!-- back to previous page --> <!-- InfoBlock -->

    The website cannot display the page

    <ID id=http500> HTTP 500</ID>
     

    Most likely causes:

    • The website is under maintenance.
    • The website has a programming error.
     

    What you can try:

     

    Refresh the page.<NOSCRIPT id=refreshPage></NOSCRIPT>

     

    Go back to the previous page.<NOSCRIPT id=goBack></NOSCRIPT>

     

    More information More information<NOSCRIPT></NOSCRIPT>

    This error (HTTP 500 Internal Server Error) means that the website you are visiting had a server problem which prevented the webpage from displaying.

    For more information about HTTP errors, see Help

    Saturday, February 10, 2007 3:21 AM
  • User1356161706 posted

    Reisel,

     Read my last blog post on http://blogs.iis.net/thomad. Setting scriptSentToBrowser:true should fix the problem for now.

     Thomas

     

    Sunday, February 11, 2007 4:01 PM
  • User-1873577010 posted
    When i attempt to run these commands i get  a Cannot read configuration file error. I am loged in as an admin account too. Any suggestions?
    Sunday, February 25, 2007 4:51 PM
  • User989702501 posted
    You need to run the command prompt in elevated mode, right mouse as select 'run as administrator', then execute the command...
    Sunday, February 25, 2007 10:09 PM
  • User-2105095215 posted

    I ran the commands listed above and some of my asp pages are working, but then again some aren't.  My page is giving the same errors as above.

     

    any other advice would be great! 

    Tuesday, March 13, 2007 4:39 AM
  • User1356161706 posted

    Can you try to narrow down the problem and send some sample code?

     

    Thursday, March 15, 2007 3:10 PM
  • User581412812 posted

    Hello thomad,

       I just happend to see your help comment in here, while searching for help as same as Reisel. You did a great job in analysing and trouble shooting. However in my case the <% = Now%>  is working fine. What I did is I make a separate asp with just <%now%> as you suggested and it worked fine. So I copied the other command line you mentioend <%windir%system..... into my orginal asp page with the database connection codes.  I wasn't very clear anyway where to put those code. So I added to the the datebase connection asp page and it didnt' work. Could you please tell me where do I add this   "%windir%\system32\inetsrv\appcmd set config -section:system.applicationHost/applicationPools -applicationPoolDefaults.processModel.loadUserprofile:false"

     Your help is greatly appreciated.

     

      Thank you.

    Sherry


     

    Friday, June 13, 2008 9:44 PM
  • User581412812 posted

    Reisel,

       Yes he did a good job. But I dont' know where to add those codes he listed. Could you help me if you fixed the problem you coudl probably help me . Thanks

    Sherry

    Friday, June 13, 2008 9:50 PM
  • User581412812 posted

    I just posted an error msg for your help on vista and asp. I forgot to include my email address so you may email me. My email address is sherryqueen31 at yahoo dot com.  Thanks

    Friday, June 13, 2008 9:52 PM
  • User545265881 posted

    reisel, you need to go into Internet Options in IE7 or control panel, and under the Advanced tab you'll see an option that says "Show friendly HTTP error messages". uncheck this option, and you'll get the asp debug messages.

    Tuesday, June 17, 2008 9:35 AM