none
VS 2015 on Windows 10 Freezes often after build

    Question

  • Hey,

    Since i'm using windows 10 and upgraded to VS 2015, my visual studio often freezes randomly after build which results in a total restart of my computer as only solution. I've tried to install 2013 again to use that version instead.  But when i create a new project, it freezes even before i can type some code into it.

    In windows 8 in combination with VS 2013 i never had this problem.

    Is there any way to solve these bugs? Has anyone yet had this problem too?

    Is there some software i'm maybe missing? Should i reset to windows 8?


    Tuesday, December 08, 2015 6:44 PM

All replies

  • Hi JarnoH,

    Thanks for your post.

    >> Is there some software i'm maybe missing? Should i reset to windows 8?

    My OS is windows 10 too. When I am using VS2015 Enterprise, it works well and never freezes.

    So I think you don’t have to reset to windows 8.

    According your description of the issue.

    First to exclude the cause of VS. I suggest you could repair your VS  and make sure there is no error during repairing the VS. Then use this repaired VS.

    If this problem still occurs when use this repaired VS. I think the cause is not in your VS.

    Since after you restart your machine, the problem can be solved. I suppose it is probably a performance issue or it is related to the environment you use.

    Since it will cost a lot of system resource when open Visual Studio, I suggest you could close other third party application in task manager before using VS to avoid performance .

    On the other hand. I suggest you could check  the hardware of you PC. Make sure your PC could reach it. You could refer to the following link:

    https://www.visualstudio.com/en-us/visual-studio-2015-system-requirements-vs.aspx



    Best Regards,

    Lake Xiao

    Thursday, December 10, 2015 9:00 AM
    Moderator
  • Hi JarnoH,

    Have you found the cause of your issue?

    If you have any update, please feel free to share here.


    Best Regards,

    Lake Xiao


    Friday, December 18, 2015 1:27 AM
    Moderator
  • Hi Xiao,

    Thanks for answer. I've tried what you said, but it didn't work. 

    So i've installed windows 10 fresh and I still have the random freezes when i close the debugging (cmd).

    I don't know what i can do anymore...

    Friendly Greetings,

    Jarno

    Wednesday, December 30, 2015 3:56 PM
  • Hi Jarno,

    Please try to reproduce you issue in logging module and check the if there is some error message in the log file.

    Running your Visual Studio with logging turned on (devenv /log) in Developer Command Prompt for VS

    The logs will be in: %APPDATA%\Microsoft\VisualStudio\Version\ActivityLog.xml

    On the other hand, try to install VS2015 update1. May be the issue will be solved.


    Best Regards,

    Lake Xiao

    Thursday, December 31, 2015 1:45 AM
    Moderator
  • Hi!

    We have the same issue on each computer of my company (about 20): heterogeneous versions of windows from 7 to 10 and all with Visual Studio 2015 from no update to Update 2.

    I generated the ActivityLog.xml file as you said and there are indeed many errors after the build. I don't really understand what the problem is, but it seems that I have many unexpected system errors.

    <entry>
      <record>2542</record>
      <time>2016/05/04 15:24:53.107</time>
      <type>Information</type>
      <source>VisualStudio</source>
      <description>Begin package load [CSharpPackage]</description>
      <guid>{13C3BBB4-F18F-4111-9F54-A0FB010D9194}</guid>
    </entry>
    <entry>
      <record>2543</record>
      <time>2016/05/04 15:24:53.140</time>
      <type>Information</type>
      <source>VisualStudio</source>
      <description>Entering function CVsPackageInfo::HrInstantiatePackage</description>
      <guid>{6CF2E545-6109-4730-8883-CF43D7AEC3E1}</guid>
    </entry>
    <entry>
      <record>2544</record>
      <time>2016/05/04 15:24:53.140</time>
      <type>Warning</type>
      <source>VisualStudio</source>
      <description>Unexpected system error mode before loading package [RoslynPackage]</description>
      <guid>{6CF2E545-6109-4730-8883-CF43D7AEC3E1}</guid>
    </entry>

    I hope this can help.

    If you want the entire file, I can send it to you.

    Thanks a lot!

    Loïc

    Wednesday, May 04, 2016 3:41 PM