locked
Data is not being loaded for a List Screen using a parameter query RRS feed

  • Question

  • I am new to lightswitch.  My application works in development, but when I publish it with Form authorization,  one of the screens is not loading. Here is more explanation:

    I am using an external SQLSERVER DB with my LS  Webapp.  I don't have any intrinsic  data.  I do have one query which I have created off of a db table which filters data. I have created a screen based on this query that allows user to filter data and then show the list that matches the filtered field(s).  This is the screen that causes trouble and data is not loaded. it shows red crosses for data fields and says: 

    “Exception has been thrown by the target of an invocation or data is not loaded check your network. “  

    My other screens are OK, but they are all based on db tables. I set the trace.axd  on and I found out that this Datasource (the query) is being qualified with the database server I am using, so application  thinks this datasource is part of my external DB: Here is trace.axd and the last one is actually the entity causing the issue(query)

    5/18/2016 12:15:17 AM  /DesktopClient/

    5/18/2016 12:15:17 AM  /DesktopClient/

    5/18/2016 12:15:17 AM  /DesktopClient/

    5/18/2016 12:15:17 AM  /DesktopClient/Silverlight.js

    5/18/2016 12:15:17 AM  /DesktopClient/Web/TMI_DAM.DesktopClient.xap

    5/18/2016 12:15:32 AM  /DesktopClient/Web/Microsoft-LightSwitch-Security-ServerGenerated-Implementation-AuthenticationService.svc/binary/GetAuthenticationInfo

    5/18/2016 12:15:35 AM  /Epicor905Data.svc/Microsoft_LightSwitch_GetCanInformation

    5/18/2016 12:15:36 AM  /Epicor905Data.svc/partimages()

    5/18/2016 12:15:43 AM  /Epicor905Data.svc/Microsoft_LightSwitch_GetCanInformation

    5/18/2016 12:15:54 AM  /Epicor905Data.svc/Microsoft_LightSwitch_GetCanInformation

    5/18/2016 12:15:54 AM  /Epicor905Data.svc/partimages(552)

    5/18/2016 12:15:55 AM  /Epicor905Data.svc/PartMTLImageInfo_VWs()

    5/18/2016 12:15:54 AM  /Epicor905Data.svc/PartMTLImageInfo_VWs()

    5/18/2016 12:16:08 AM  /Epicor905Data.svc/SearchImagesByParameter()  ------à Gives Code 500 - This is the query that has been created based on setting some  optional parameters  on parimages table. The screen does not show data

    Can you please help?

    Thank you in advance

    Wednesday, May 18, 2016 9:16 AM

Answers

  • Hi FarMeh789,

    According to the error code 500, this problem should be the server side issue. But it doesn't provide detailed error message for this issue. Please try use Fiddler tool to get detailed information for this problem.

    And if possible, please tell us how do you implement this screen and how do you deploy your LightSwitch application and database to server. I need some detailed steps to try reproduce your problem in my side to figure out what happened.

    Best Regards,
    Weiwei


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    • Proposed as answer by Weiwei CaiModerator Wednesday, June 1, 2016 9:45 AM
    • Marked as answer by Angie Xu Thursday, June 2, 2016 7:55 AM
    Thursday, May 19, 2016 8:34 AM
    Moderator