none
Cannot execute .NET application RRS feed

  • Question

  • Hello everybody,
    hope this is the right place for my question. I'm having a really bad troubles now. I made an application in MSVC++ 2005 Express, working over .NET 2.0 framework. On my developing PC (1), the application runs OK (both Debug and Release mode), but on my second PC (2), the application doesn't even run, saying just "Error executing program" in Total Commander, or something about "wrong side-by-side configuration" in Explorer.

    PC 1 (developing) is Vista, MSVC++2005 Express, PSDK for Windows Server 2003 R2 and .NET 2.0; app is compiled with /MDd and /clr options.
    PC 2 (user) is Vista and .NET 2.0 (no PSDK nor MSVC). I tried to install the Visual Studio C++ Redistributable Pack, also used the Dependency Walker to see all the libraries my app needs and copied them on the PC2, but still no luck. I tried to switch to Admin mode in Vista or use the Compatibility mode, but the problem is the same all the time ...

    I'm going mad, because the app I'm making is a part of my bachelor thesis, which needs to be completed at the beginning of July, and it's "not working"  :-(

    I think you're my last chance...

    Thanks in advance for all your replies, hope they will solve my troubles.
    • Edited by kibitzer_CZ Thursday, June 19, 2008 8:02 PM new info about error
    Thursday, June 19, 2008 7:18 PM

Answers

  • OK...solved now.

    The problem was in that I was using /MDd in the release mode instead of /MD, thinking it's almost the same as /MD. In fact, the /MDd still created a debug version...

    Also had some issues with MSVC++ 2005 Redistributable, so I used Merge Modules and followed step-by-step directions on Nikola Dudar's Weblog to create my own MSI installer with files needed to execute my application.

    Now everything is going right :)
    • Marked as answer by kibitzer_CZ Friday, June 20, 2008 12:03 PM
    Friday, June 20, 2008 12:02 PM