none
Auto quotes in VS 2013.. make it stop!

    Question

  • OK.. really stupid but I can't seem to take care of this..

    I'm used to VB 2008.. when I would put in code such as:

    strVariable = "

    I could type the value, then hit enter, and VB would insert the second quote marks as:

    strVariable ="value"

    No problem..

    But now I am using VS 2013.. and if I do the same thing, VS automatically puts the second quote in right away..

    strVariable = ""

    with the cursor in-between the quotes.. so when I type the value, and hit enter now, I have:

    strVariable = "value"

    "

    with the second quote then moved to the next line which of course causes an error! The only way around this is to hit the 'right arrow' to get out from the quotation marks.. which is a PITA.  This really causes an issue when doing something like:

    #Region ""

    The second quote is automatic.. then if you hit enter, the second (closing) code isn't added..

    #Region "Region name"

    "

    Where it should work like this:

    # Region "Region name"

    #End Region

    But that only works if you again 'right arrow' out of the quotation marks..

    I have tried looking through the options, and also online but only finding info on older versions which doesn't help.  What I want to do is either have it work like it did in 2008, or not do the quotes at all and let me do them.. either way, as long as it stops auto inserting that second quote right away.

    TIA

    Tuesday, November 24, 2015 2:09 PM

Answers

  • Hi ColtsFanMN,

    You can try something like this:

    1. Tools
    2. Options
    3. Text Editor
    4. C# or some other language for you
    5. General
    6. Uncheck Automatic brace completion

    Best regards!
    (If this was helpful for you, propose it as an answer)

    • Marked as answer by ColtsFanMN Tuesday, November 24, 2015 3:03 PM
    Tuesday, November 24, 2015 2:57 PM

All replies

  • Hi ColtsFanMN,

    You can try something like this:

    1. Tools
    2. Options
    3. Text Editor
    4. C# or some other language for you
    5. General
    6. Uncheck Automatic brace completion

    Best regards!
    (If this was helpful for you, propose it as an answer)

    • Marked as answer by ColtsFanMN Tuesday, November 24, 2015 3:03 PM
    Tuesday, November 24, 2015 2:57 PM
  • Thanks!

    About the only thing I didn't try, thinking it would only work for C# (I use VB) but it worked like a charm.. Thanks!

    Tuesday, November 24, 2015 3:04 PM