none
VMM windows setup encountered an internal error while loading or searching for an unattend answer file RRS feed

  • Question

  • Creating a VM in VMM using an answerfile is failing.

    We have a Template for W2K8 R2 which when used on its own has no problems being used in creating a VM. I am trying to create a process where the creation of a VM sets the IP settings amongst a few other tweaks so that it is basically ready to be handed over to a user almost immediately after adding to the domain manually as we don't want to expose any passwords.

    There is an IP Address which we have reserved for the initial creation to get the VM on the network and then we have a powershell script in the template which will connect to a SQL DB which holds assigned and unassigned IP addresses to get the next available and then using WMI changes the IP address appropriately. Before I added the IP settings to the answer file everything seemed to work in setting the International settings however now it does not.

     The following error is returned in VMM when the Job Fails:

    Error (609) : - Virtual Machine Manager cannot detect a heartbeat from the specified virtual machine. Either the virtual machine is not running or Virtual Machine Additions is not installed.
    Recommended Action : - Verify the status of the virtual machine by connecting to it using Virtual Machine Remote Client (VMRC), and then try the operation again.

    When i actually try and connect to the Virtual machine it is in the middle of the setup process giving me the error "VMM windows setup encountered an internal error while loading or searching for an unattend answer file" . Please see below the answer file being used.

     

    Thanks 

    <?xml version="1.0" encoding="utf-8"?>
    <unattend xmlns="urn:schemas-microsoft-com:unattend">
        <settings pass="oobeSystem">
            <component name="Microsoft-Windows-International-Core" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
                <InputLocale>0809:00000809</InputLocale>
                <SystemLocale>en-GB</SystemLocale>
                <UILanguage>en-GB</UILanguage>
                <UILanguageFallback>en-GB</UILanguageFallback>
                <UserLocale>en-GB</UserLocale>
            </component>
            <component name="Microsoft-Windows-Shell-Setup" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
                <FirstLogonCommands>
                    <SynchronousCommand wcm:action="add">
                        <Order>2</Order>
                        <CommandLine>%windir%\system32\WindowsPowerShell\v1.0\powershell.exe -command C:\Windows\Temp\NetworkConfigurator.ps1 21</CommandLine>
                        <RequiresUserInput>false</RequiresUserInput>
                        <Description>Sets Network Settings</Description>
                    </SynchronousCommand>
                    <SynchronousCommand wcm:action="add">
                        <CommandLine>%windir%\system32\WindowsPowerShell\v1.0\powershell.exe  -command set-Executionpolicy remotesigned -Force</CommandLine>
                        <Order>1</Order>
                        <Description>Before any scripts can be run setting of execution policy must be run first</Description>
                        <RequiresUserInput>false</RequiresUserInput>
                    </SynchronousCommand>
                </FirstLogonCommands>
            </component>
        </settings>
        <settings pass="specialize">
            <component name="Microsoft-Windows-ServerManager-SvrMgrNc" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
                <DoNotOpenServerManagerAtLogon>true</DoNotOpenServerManagerAtLogon>
            </component>
            <component name="Microsoft-Windows-DNS-Client" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
                <DNSSuffixSearchOrder>
                    <DomainName wcm:action="add" wcm:keyValue="1">DNSDomain1</DomainName>
                    <DomainName wcm:action="add" wcm:keyValue="2">DNSDomain2</DomainName>
                    <DomainName wcm:action="add" wcm:keyValue="3">DNSDomain3</DomainName>
                </DNSSuffixSearchOrder>
                <Interfaces>
                    <Interface wcm:action="add">
                        <DNSServerSearchOrder>
                            <IpAddress wcm:action="add" wcm:keyValue="1">AnIPAddress1</IpAddress>
                            <IpAddress wcm:action="add" wcm:keyValue="2">AnIPAddress2</IpAddress>
                        </DNSServerSearchOrder>
                        <Identifier>Local Area Connection</Identifier>
                        <EnableAdapterDomainNameRegistration>true</EnableAdapterDomainNameRegistration>
                    </Interface>
                </Interfaces>
            </component>
            <component name="Microsoft-Windows-TCPIP" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
                <Interfaces>
                    <Interface wcm:action="add">
                        <Ipv4Settings>
                            <DhcpEnabled>false</DhcpEnabled>
                        </Ipv4Settings>
                        <UnicastIpAddresses>
                            <IpAddress wcm:action="add" wcm:keyValue="1">ReservedIPAddress/24</IpAddress>
                        </UnicastIpAddresses>
                        <Routes>
                            <Route wcm:action="add">
                                <NextHopAddress>GatewayIP1</NextHopAddress>
                                <Identifier>1</Identifier>
                            </Route>
                            <Route wcm:action="add">
                                <Identifier>2</Identifier>
                                <NextHopAddress>GatewayIP2</NextHopAddress>
                            </Route>
                        </Routes>
                        <Identifier>Local Area Connection</Identifier>
                    </Interface>
                </Interfaces>
            </component>
            <component name="Microsoft-Windows-NetBT" processorArchitecture="amd64" publicKeyToken="31bf3856ad364e35" language="neutral" versionScope="nonSxS" xmlns:wcm="http://schemas.microsoft.com/WMIConfig/2002/State" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
                <Interfaces>
                    <Interface wcm:action="add">
                        <NameServerList>
                            <IpAddress wcm:action="add" wcm:keyValue="1">WINS1</IpAddress>
                            <IpAddress wcm:action="add" wcm:keyValue="2">WINS2</IpAddress>
                        </NameServerList>
                        <Identifier>Local Area Connection</Identifier>
                    </Interface>
                </Interfaces>
            </component>
        </settings>
        <cpi:offlineImage cpi:source="wim://servername/temp/wim_output/2008r2.wim#Windows 2008 R2" xmlns:cpi="urn:schemas-microsoft-com:cpi" />
    </unattend>

     

    Wednesday, October 6, 2010 8:28 AM

Answers