locked
App Freezing In Instruments RRS feed

  • Question

  • User18718 posted

    I've been trying to profile for memory leaks a few days now, and I finally got the symbols loaded correctly so that I can see meaningful line numbers. However, my app now locks up frequently in the middle of an Instruments run, so I have to stop everything and start over again.

    This seems to happen around task-based operations. For example, I have a log-in screen that throws up an activity indicator while the server is authenticating the user. Outside of Instruments everything runs fine. Within Instruments the task never completes and the activity indicator hangs around forever.

    Is this a common thing and is there anything I can do to fix it? Would boosting my RAM to 16 gigs (from 8) help out?

    Monday, August 4, 2014 7:19 PM

All replies

  • User39 posted

    There is a known issue with Instruments where Instruments deadlocks the app: https://bugzilla.xamarin.com/show_bug.cgi?id=19379

    As far as we've been able to determine, it's a bug in Instruments (no matter what the app does, Instruments shouldn't end up deadlocking it).

    Thursday, August 7, 2014 2:26 PM
  • User18718 posted

    Thanks for the response. I've found your suggestions here very helpful http://stackoverflow.com/questions/19657116/xamarin-ios-and-instruments-profiling-trouble. I'll follow the bug for updates.

    Thursday, August 7, 2014 6:22 PM
  • User51580 posted

    @RolfBjarneKvinge? @ChaseCarlile? - Is there any update on this? I'm seeing the same kind of thing where the app seems to hang when doing async task operations. After the user logs in, we launch 5-6 threads via Task.Run to load some data in the background. The app usually hangs at this point, but not always. If I can get past this point, the app will lock up shortly after on another async service call.

    Monday, October 6, 2014 2:12 PM
  • User18718 posted

    The only update I'm aware of is in the bugzilla link. Basically it's still an issue in XCode6. I'm hoping the profiler announced today at Evolve won't have these problems. It didn't appear to rely on Instruments in the demo.

    Thursday, October 9, 2014 2:56 AM
  • User51603 posted

    Problem still remains in XCode 7. I tried with both debug & release modes, no luck. App freezes when it executes async operations during profiling with Instruments. Any workaround?

    Tuesday, April 26, 2016 4:14 PM
  • User120247 posted

    This appears to still be an issue on our project, symptoms as described.

    Thursday, May 26, 2016 5:47 PM
  • User39613 posted

    I have the same problem, Instruments starts the app which then stops and freezes... I can't use any tool to track memory leaks, I have issues with the Xamarin Profiler too, that's really a paint point right now :(

    Tuesday, June 28, 2016 4:20 PM
  • User22593 posted

    Thought I would just add that we are struggling with this problem as well. There doesn't seem to be a good option when it comes to profiling memory problems.

    Tuesday, October 4, 2016 5:05 PM
  • User326 posted

    I also have the same problems / pian like Cyril:

    Instruments starts the app which then stops and freezes... I can't use any tool to track memory leaks, I have issues with the Xamarin Profiler (0.36.0) too, that's really a paint point right now :(

    Saturday, October 8, 2016 8:55 AM
  • User5687 posted

    Same problem with my app... It freezes after few seconds. Tried nearly all options in Instruments. only checking "Only track VM allocations" will allow the app to launch with Instruments, but results with this options are not really useful.

    Any news or comments from Xamarin?

    Thursday, December 1, 2016 10:28 PM
  • User30591 posted

    Same here. App freezes when using Instruments... How can we track memory leaks?

    Wednesday, May 31, 2017 10:07 PM
  • User43729 posted

    Same here. I'm using loads of async so that could be it. Can't afford Xamarin enterprise to try their profiler!

    Wednesday, August 30, 2017 2:45 PM
  • User10329 posted

    Same issue with XCode/Instruments 9.2

    Monday, March 5, 2018 9:38 PM
  • User321437 posted

    Same issue happens with Xcode/Instruments 9.3 ,any solutions or workaround found for this issue?

    Tuesday, April 17, 2018 9:31 AM
  • User370909 posted

    I am also facing the same issue app freeze on startup with Xcode/Instruments 10.1. Have someone find the solution for the same?

    Friday, November 16, 2018 9:51 AM
  • User104401 posted

    Same problem here with Instruments Version 10.1 (10B61)

    Wednesday, February 6, 2019 12:57 PM