locked
DB Memory High RRS feed

  • Question

  • hi,

    Need any feedback, why my DB Memory so high and how to solve. tq.

    Friday, November 23, 2012 2:45 AM

Answers

  • If youdo not cap your SQL Server memory it will keep increasing till there is memory pressure in OS. Can you be more specific on your problem.

    Reduce your max server memory to reduce memory usage of SQL Server.


    Thank you,

    Karthick P.K |My Site|My Scribbles |Blog Space |Twitter|My Facebook Group|

    www.Mssqlwiki.com

    Please click the Mark as answer button and vote as helpful if this reply solves your problem

    • Proposed as answer by Shulei Chen Monday, November 26, 2012 3:03 AM
    • Marked as answer by Shulei Chen Tuesday, December 4, 2012 6:19 AM
    Friday, November 23, 2012 3:20 AM
  • you might be using SQL Server 64 bit and it is bad consumer for memory for good purpose.it occupies available memory and stores it in Buffer Manager, for more information run DBCC MEMORYSTATUS  to verify its  memory usage,

    memory cap is the only answer 

    EXEC sp_configure 'show advanced options', '1'
    RECONFIGURE WITH OVERRIDE

    EXEC sp_configure 'min server memory', '0'

    EXEC sp_configure 'max server memory', '3000'
    RECONFIGURE WITH OVERRIDE

    EXEC sp_configure 'show advanced options', '0'
    RECONFIGURE WITH OVERRIDE

    3000MB is what i took to from my desktop.




    Ramesh Babu Vavilla MCTS,MSBI

    • Proposed as answer by Shulei Chen Monday, November 26, 2012 3:03 AM
    • Marked as answer by Shulei Chen Tuesday, December 4, 2012 6:19 AM
    Friday, November 23, 2012 10:11 AM

All replies

  • If youdo not cap your SQL Server memory it will keep increasing till there is memory pressure in OS. Can you be more specific on your problem.

    Reduce your max server memory to reduce memory usage of SQL Server.


    Thank you,

    Karthick P.K |My Site|My Scribbles |Blog Space |Twitter|My Facebook Group|

    www.Mssqlwiki.com

    Please click the Mark as answer button and vote as helpful if this reply solves your problem

    • Proposed as answer by Shulei Chen Monday, November 26, 2012 3:03 AM
    • Marked as answer by Shulei Chen Tuesday, December 4, 2012 6:19 AM
    Friday, November 23, 2012 3:20 AM
  • you might be using SQL Server 64 bit and it is bad consumer for memory for good purpose.it occupies available memory and stores it in Buffer Manager, for more information run DBCC MEMORYSTATUS  to verify its  memory usage,

    memory cap is the only answer 

    EXEC sp_configure 'show advanced options', '1'
    RECONFIGURE WITH OVERRIDE

    EXEC sp_configure 'min server memory', '0'

    EXEC sp_configure 'max server memory', '3000'
    RECONFIGURE WITH OVERRIDE

    EXEC sp_configure 'show advanced options', '0'
    RECONFIGURE WITH OVERRIDE

    3000MB is what i took to from my desktop.




    Ramesh Babu Vavilla MCTS,MSBI

    • Proposed as answer by Shulei Chen Monday, November 26, 2012 3:03 AM
    • Marked as answer by Shulei Chen Tuesday, December 4, 2012 6:19 AM
    Friday, November 23, 2012 10:11 AM