UIAutomation is not working in minimized Remote VDI machines


  • Hello All,

    I am in the process of automating a desktop application (based on C sharp) using UIAutomation in legacy VBA.

    I am actually working in Remote VDI machine. My script is developed inside VDI and the Application under Test is also inside the VDI. I use my local machine only to access the VDI machine. Nothing is done in the Local machine apart from connecting to the VDI Machine. The automation script works great  in the VDI machine. But when I minimize the VDI machine, the script is not working for some controls like Listview, Tab etc.

    Buttons, Text boxes and Links are working fine even when I minimize the VDI machine window.

    My VDI machine window will automatically get locked and minimized after some 3 minutes of  inactivity from the user.

    So Somehow I need to make my script run even if the  VDI window is minimized. I tried this in a physical remote machine as well. The same is the case where listview,Tab controls are not getting executed when Remote machine window is minimized.

    Could anyone help me with this issue?



    • Moved by Carl Cai Monday, December 16, 2013 9:35 AM (from vb) more related
    Sunday, December 15, 2013 6:05 PM

All replies

  • Hi,

    Welcome to MSDN.

    For issues about using UI Automation from a desktop app, you could post them in the Windows Desktop Development for Accessibility and Automation forum.

    I have moved this thread in   Windows Desktop Development for Accessibility and Automation forum for more dedicated support.

    Thanks for your understanding.


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Monday, December 16, 2013 9:33 AM
  • Hi,

    I'm assuming your remote connection to the PC in question is via RDP (i.e., MSTSC.exe). 

    You seem to have two different problems here: firstly, you need to disable the machine from getting locked after inactivity. You can do this directly through the PC's policy management, or, if you're part of a corporate network that limits policy management from client desktops, you can also use applications such as Caffeine that keep the desktop session active.

    The second, and more complicated problem, is the fact that by default, RDP will disable user interaction with the desktop when the remote session window is minimized. This can be solved by modifying the appropriate registry keys to override this setting -- I have successfully done it in the past, see more information here.

    Monday, January 06, 2014 10:06 AM