none
EDI Receive Configuration Problems... RRS feed

  • Question

  •  

    I am attempting to receive an EDI file, convert it to XML and map that file before sending it out again. Unfortunately i have yet to have the correct party/receive pipeline settings to allow the file to even be converted. The weird thing is that i am using an X12 4010 810 file, but every error message i receive says its trying to read an X12 4050 file.

     

    This hasnt always been the case, Last week i posted about some issues i was having with this same file and the error messages all said it was a 4010 file. but that is no longer the case... I am using the X12 0410 810 Schema that comes with biztalk 2006 R2. Here is the input file im using and the error, i have jpgs of the config settings i have in there that i can send via email. thanks for you help and patience as i am a brand new biztalk user.

     

    Input File:

    ISA~00~          ~00~          ~ZZ~XXXCENTRAL2     ~ZZ~XXXXXEDI    ~080604~0716~X~00401~000001146~0~P~:+GS~IN~XXXCENTRAL2~PP~20080604~0716~1145~X~004010+ST~810~0001+BIG~20080603~1110870~20080602~~86525~~DR+N1~ST~XXXXX SHAPES  INC.+FOB~DE~RT~XXX CORPORATE TR~~~ZZ~PREPAID & ADDED+IT1~001~22~GA~51.52~RE~BP~UC105042~PO~407611-001~LT~51542+QTY~FL~1+CTP~~EUP~113344+PID~F~~ZZ~DRUM~DURANAR SADDLE BROWN+TDS~11334400+AMT~ZZ~220+SE~11~0001+ST~810~0001+BIG~20080603~1111194~20080602~~86525~~DR+N1~ST~XXXXX SHAPES  INC.+FOB~DE~RT~XXX CORPORATE TR~~~ZZ~PREPAID & ADDED+IT1~001~200~GA~18.84~RE~BP~UC103346*~PO~407615-001~LT~46717+QTY~FL~5+CTP~~EUP~376800+PID~F~~ZZ~DRUM~DURACRON 100 FX WHITE+TDS~37680000+AMT~ZZ~2000+SE~11~0002+GE~2~1145+IEA~1~000001146+

     

    Errors:

    Error encountered: ERROR (17), interchangenr 10118 :

    The order of the segments is incorrect. Check the EDI schema.source format: [5 00405 ,X12-4050]

    source document: [unknown]

    source segment: [data#0,def#0,tag=I ,name=unknown], missing interchange header: [ISA ] (msgnr:0 segnr:0)(line:0 pos:0 filepos:0)

    sender: [][] [XXXCENTRAL2][ZZ][XXXCENTRAL2]

    sender: [][] [XXXCENTRAL2][ZZ][XXXCENTRAL2]sender: [][] [XXXCENTRAL2][ZZ][XXXCENTRAL2]

    sender: [][] [XXXCENTRAL2][ZZ][XXXCENTRAL2]sender: [][] [XXXCENTRAL2][ZZ][XXXCENTRAL2]

    sender: [][] [XXXCENTRAL2][ZZ][XXXCENTRAL2]sender: [][] [XXXCENTRAL2][ZZ][XXXCENTRAL2]

    sender: [][] [XXXCENTRAL2][ZZ][XXXCENTRAL2]recipient: [][] [XXXXXEDI][ZZ][PP]

    recipient: [][] [XXXXXEDI][ZZ][PP]

    source format: [5 00401 ,X12-4010]

    source document: [unknown]

    source segment: [data#0,def#0,tag=GS ,name=unknown]

     

     

    Error encountered: ERROR (17), interchangenr 10063 :

    The order of the segments is incorrect. Check the EDI schema.source format: [5 00405 ,X12-4050]

    source document: [unknown]

    source segment: [data#0,def#0,tag=I ,name=unknown], missing

    document header: [ST ] (msgnr:0 segnr:0)(line:0 pos:0 filepos:0)

    sender: [][] [XXXCENTRAL2][ZZ][XXXCENTRAL2]

    sender: [][] [XXXCENTRAL2][ZZ][XXXCENTRAL2]sender: [][] [XXXCENTRAL2][ZZ][XXXCENTRAL2]

    sender: [][] [XXXCENTRAL2][ZZ][XXXCENTRAL2]sender: [][] [XXXCENTRAL2][ZZ][XXXCENTRAL2]

    sender: [][] [XXXCENTRAL2][ZZ][XXXCENTRAL2]sender: [][] [XXXCENTRAL2][ZZ][XXXCENTRAL2]

    sender: [][] [XXXCENTRAL2][ZZ][XXXCENTRAL2]recipient: [][] [XXXXXEDI][ZZ][PP]

    recipient: [][] [XXXXXEDI][ZZ][PP]

    source format: [5 00401 ,X12-4010]

    source document: [unknown]

    source segment: [data#0,def#0,tag=GS ,name=unknown]

     

     

     

     

     

    Thanks Again,

      Kevin

    Monday, June 16, 2008 1:26 PM

All replies

  • Two things pop into mind.

    1.  In PAM, are you sure you have the correct version number in the GS settings page for party as interchange sender?

    2.  In your map, are you sure your schema of the 810 is the correct version?

     

    JT

     

    Monday, June 16, 2008 9:18 PM
  • You get these errors because the ISA segment is not correct.
    All fields in the ISA segment have a fixed length and the values should have exactly that length. In your sample file, some fields do NOT have the correct length.
    X12 is using this fixed length of the ISA, so that the separator characters can be determined (because they are on fixed positions). Your ISA is too short though, so the translator is using a wrong character as the segment terminator. Because a wrong segment terminator has been determined, the reading of all following segments will fail...

    Please complare your ISA (line A below) with a correct example (line B below):

    A: ISA~00~          ~00~          ~ZZ~XXXCENTRAL2     ~ZZ~XXXXXEDI    ~080604~0716~X~00401~000001146~0~P~:+
    B: ISA~00~          ~00~          ~ZZ~7654321        ~ZZ~1234567        ~030318~1816~U~00401~856401000~0~P~:+

    You see here that the ISA06 and ISA08 fields (sender/recipient identification) in your ISA do not have the correct length. Both of them should be exactly 15 characters, but in your file the ISA06 has 16 characters, and ISA08 has only  12 characters. Fix that and the translation will work.
    Saturday, February 14, 2009 12:48 AM
  • Hi,
        There are some other problems including above one that is ISA06 and ISA08 fields are not of correct length. 

    1- You are using X as ISA11 that is repetition seperator and X is used inside the transaction set too if you really want to use repetition separator then in party settings you need to check the box USE ISA11 as repetition separator in the sender settings. If you do not want to use then make it Default(U).

    2- Control number for ST-SE segment is not matching. ST02 is 0001 but SE02 is 0002 that is a mismatch.

    I modified the input that is following:

    ISA~00~          ~00~          ~ZZ~XXXCENTRAL2    ~ZZ~XXXXXEDI       ~080604~0716~U~00401~000001146~0~P~:+GS~IN~XXXCENTRAL2~PP~20080604~0716~1145~X~004010+ST~810~0001+BIG~20080603~1110870~20080602~~86525~~DR+N1~ST~XXXXX SHAPES  INC.+FOB~DE~RT~XXX CORPORATE TR~~~ZZ~PREPAID & ADDED+IT1~001~22~GA~51.52~RE~BP~UC105042~PO~407611-001~LT~51542+QTY~FL~1+CTP~~EUP~113344+PID~F~~ZZ~DRUM~DURANAR SADDLE BROWN+TDS~11334400+AMT~ZZ~220+SE~11~0001+ST~810~0001+BIG~20080603~1111194~20080602~~86525~~DR+N1~ST~XXXXX SHAPES  INC.+FOB~DE~RT~XXX CORPORATE TR~~~ZZ~PREPAID & ADDED+IT1~001~200~GA~18.84~RE~BP~UC103346*~PO~407615-001~LT~46717+QTY~FL~5+CTP~~EUP~376800+PID~F~~ZZ~DRUM~DURACRON 100 FX WHITE+TDS~37680000+AMT~ZZ~2000+SE~11~0001+GE~2~1145+IEA~1~000001146+


    Try this and let me know if any problem coming again.



    Thanks
    Gyan
    Monday, February 16, 2009 7:42 AM
  • I would check to see if the ISA segment is correct length, as it does not look correct, but maybe it was pasted in and the forum does not display it correctly.
    Monday, February 16, 2009 6:04 PM
  • Prakash_P[MSFT] said:

    1- You are using X as ISA11 that is repetition seperator and X is used inside the transaction set too if you really want to use repetition separator then in party settings you need to check the box USE ISA11 as repetition separator in the sender settings. If you do not want to use then make it Default(U).

    2- Control number for ST-SE segment is not matching. ST02 is 0001 but SE02 is 0002 that is a mismatch.



    1- The error messages point out that the 'old' BaseEDI is used, and not R2-Edi. BaseEdi doesn't support the repetition separator.

    2- Good call! But you missed that there are actually 2 STs in the interchange :-)
        So, instead of changing the SE02 at the end to 0001, the ST02 in the middle should be changed to 0002
          ST~810~0001+ 
               ......
          SE~11~0001+
          ST~810~0002+ 
               ......
          SE~11~0002+

    Gerard
    Monday, February 16, 2009 6:46 PM
  • Hi,
         1- I saw in the Kevin's first response that he is using biztalk 2006 R2 (I am using the X12 0410 810 Schema that comes with biztalk 2006 R2) . So I thought he is using the Biztalk server 2006 R2. Kevin can you confirl which version of Biztalk are you using.


    2- You are right that there are two ST-SE (interchanges). I thought if any one is not using the option duplicate transaction set control number suspend option then we can change SE02 to 0001 too. Anyways Both will work fine.



    Thanks
    Gyan


    Tuesday, February 17, 2009 10:49 AM