locked
Formulas and parameter fields not displaying in rendered report RRS feed

  • Question

  • I have an rpt file I created via the VS2008 Crystal Reports client.  I've placed the values of two parameter fields onto the report to show a date range; however, when I call the CrystalReportViewer1.ShowFirstPage() method, I get the report, sans the parameter fields.  I'm encountering the same thing with formulas I place onto the report.  The formula fields are displayed in the VS2008 Crystal Reports client (by their names), but when the report is actually rendered, that space is blank.

     

    Is there some method I need to execute or some property I need to set to get this data to display ?

     

    Thanks in advance.

     

    Matt

    Monday, July 11, 2011 2:29 PM

Answers

  • Hi M.

    That's odd. Try dropping in a text object and then drop the parameters and the formulae into each text object.

    Don


    Don Williams
    Monday, July 11, 2011 9:37 PM

All replies

  • I just noticed that, whereas the Crystal Reports XI thick client displayed my parameter fields in the format of @Date1 for the Date1 parameter, this client for VS2008 displays the parameter as ?@Date1.  I'm willing to be that the data is not stored when that field is rendered.  </sigh>  I'll probably have to stick a field for my header into a subreport and then bind that field to a string. 
    Monday, July 11, 2011 2:45 PM
  • Hi M.

    That's odd. Try dropping in a text object and then drop the parameters and the formulae into each text object.

    Don


    Don Williams
    Monday, July 11, 2011 9:37 PM