none
AppContainers_test fails with error during pre-test configuration checks RRS feed

  • Question

  • Hello,

    AppContainers_test fails with error during pre-test configuration checks:

    "[FAIL] The machine is not properly configured for testing: the test directory "C:\Windows\SYSTEM32\" is not ACL'd to allow execute permission for "APPLICATION PACKAGE AUTHORITY\ALL APPLICATION PACKAGES"

    But that kind of permission for APPLICATION PACKAGE AUTHORITY\ALL APPLICATION PACKAGES was allowed, also i tried to allow full access, but error was the same.

    In the test WindowsFilteringPlatform_Tests, the same requirement "REQ - Wfp-based products must not block App Container apps operating within their declared network intentions by default" was checked successfully.

    How can i pass successfully AppContainers_test? 

    I installed lastest versions of QFE and filters on my server, but it didn't help.
    Friday, June 7, 2013 8:50 AM

All replies

  • It seems that your Test Account does not have the permission to do the asked actions. Maybe it could be a permission problem with your account. Have you verified that your account (must be DTMLLUAdminUser or something like that) have the maximum permissions.
    Monday, June 10, 2013 9:58 AM
  • DTMLLUAdminUser has the maximum permissions but test fails with the same error
    • Edited by sergey.m.g Monday, June 10, 2013 11:00 AM
    Monday, June 10, 2013 11:00 AM
  • Hi,

    By default "DTMLLUAdminUser" has the all permissions no need to check but once check  other accounts by using help of the following url:

    http://msdn.microsoft.com/en-us/library/windows/hardware/hh998122.aspx


    Yesubabu Gude

    Monday, June 10, 2013 11:36 AM
  • From the test developer and tester:

    -Verify "APPLICATION PACKAGE AUTHORITY\ALL APPLICATION PACKAGES" NT account has access to the AppDomain.CurrentDomain.BaseDirectoryaccount. 

    -Verify the test is actually running under DTMLLUUAdminUser account, is DTMALLUAdminUser the first/only user account logged in when the test is running?

    -Verify that the DTMLLUAdminUser account actually has admin privileges -- has this been changed/modified by the user unintentionally?


    This posting is provided "AS IS" with no warranties, and confers no rights

    Thursday, June 13, 2013 6:03 PM