none
Maximum length in Edifact documents with release characters RRS feed

  • Question

  • I am attempting to send out an Edifact D96A Orders message using the EDI pipeline in BizTalk 2009.

    The syntax specified for the party is UNOC:1

    When mapping to the IMD segment (defined as AN35 in the D96A specification) we are truncating out input to 35 characters, but we receive an error from the Edi assembler when a field large that 35 characters contains a character that needs to be released, it appears that the release character is being counted in our field length.

    The exact error we are seeing is:

    Details: Error: 1 (Segment level error)
     SegmentID: IMD
     Position in TS: 13
     39: Data element too long

    Error: 2 (Field level error)
     SegmentID: IMD
     Position in TS: 13
     Data Element ID: C27304
     Position in Segment: 4
     Position in Field: 4
     Data Value: AAAAA AAAA?' AAAA &AAAAAAAAAAAAA AAA
     39: Data element too long

    I've tried escaping the characters myself and including this in the truncation logic, but the serializer actually escapes the escape characters!

    This behaviour appears to be contrary to the edifact specification:

    >When used, the release character is not counted in the length of the
    >data element value.

    Is there a setting that will modify this behaviour?

    Regards,

    David Hall

     

    Monday, March 22, 2010 5:59 AM

Answers

  • Hi,

        This a known issue in BTS09. For work around you can increase the length of concerned data element. I know this should not be done according to standards.

    Otherwise open a Ticket for this bug to your Microsoft support.

     

    Thanks

    Gyan

     


    If this answers your question, please mark it as "Answered".
    • Proposed as answer by Nikhil J Monday, March 22, 2010 9:36 AM
    • Marked as answer by David Hall NZ Monday, March 22, 2010 8:55 PM
    Monday, March 22, 2010 6:39 AM