none
Empty File from Send Port RRS feed

  • Question

  • Anytime BizTalk writes a file through a Send Port that has been generated after an EDI Assembly or Dissassembly it creates the resulting document PLUS an empty file.  When collecting these files BizTalk is OK because it ignores the empty file, but I have another system that is erroring on this file.

     

    I have verified that this exists in both my Test and Production environments.  Why does BizTalk create this empty file and how can I make sure it doesn't get created?

     

    Thanks,

    David

    Monday, July 14, 2008 6:54 PM

All replies

  • I looked in HAT and can see two separate transmissions for the files.  The one that produces the actual EDI document says it is using the FILE Event/Adapter.  The other file has a blank entry for Event/Adapter in HAT and yet creates a file.  Has anyone seen such a thing in BizTalk before?

     

    Thanks again,

    David

    Monday, July 14, 2008 10:02 PM
  • We haven't seen this issue before. It may be due to another system reading the output files and open the handle on it. Can try the EDI scenario without starting the another system or change file location?

      

     

    Tuesday, July 15, 2008 4:04 AM
  • I actually found the issue with BizTalk only.  So, the other system is not interfering.  BizTalk is the system that is creating the file.  Any suggestions that might point me in the right direction would be greatly appreciated.

     

    Thanks again,

    David

    Tuesday, July 15, 2008 4:01 PM
  • Can you check if you have only one send port running on your host and it is pointing to a write file location that is totally isolated. Also turn off, 997 and TA1. If you still see more than one doc being generated, we'll have to look at your input doc and settings to repro it. At that point you may have to come though Biztalk Support channel.

     

    BTW, what did u mean by Biztalk ignores the blank document and uses only the edi doc. After the doc is dropped by send port, Biztalk's job is done right!

     

    regds

    Ravi

     

    Wednesday, July 16, 2008 6:12 AM
    Moderator
  • Hi David, I am having the same issue. Could you please let me know how were you able to fix this issue if you still remember ? I don't have any external system running. Thank you very much. Aparna
    Thursday, October 29, 2009 8:49 PM
  • Any error in the event log in BizTalk and (if applicalble) the remote system?
    Is the Send port pointing to a remote location? Thenyou should take a networkcapture (e.g. Netmon) to see what is actually transferred.

    I have seen empty files when using EDI over AS2. The issue was that the certificate was not setting up probably.
    Friday, October 30, 2009 9:55 AM
  • Thank you, Stern.

    There are no errors in the event log. The send port is not pointing to remote location. Its just pointing to a local folder. Its a very simple project(my very first BizTalk project) which reads a flat file and writes to a Send Port. Everything was working fine until I added an Orchestration. After I added the Orchestration I redeployed my solution and from then I am seeing this problem (writing 2 files - one with the data and the other an empty file.)

    Friday, October 30, 2009 6:30 PM
  • Has anyone figured out this issue.  I have experiencing the same behavior with AS2 messages.

    Thanks

    Thursday, February 4, 2010 5:03 PM
  • If a non-EDI message is sent over AS2 in synchronous mode, BizTalk Server will return the MDN over that synchronous connection and then close the connection. The MDN will be generated by the AS2Receive pipeline, routed by that pipeline to the MessageBox, and then automatically picked up by the AS2Send pipeline that is part of the request response receive port.

    Your send port is subscribing to both the payload and the mdn. Add an extra filter to your send port to not pick up the mdn as well; filters on the BizTalk property IsAS2PayloadMessage == True

    Check microsoft paper: http://msdn.microsoft.com/en-us/library/bb260010(v=bts.70).aspx

    • Proposed as answer by Mazin Alassaf Thursday, February 14, 2013 3:51 PM
    Wednesday, March 2, 2011 10:59 AM
  • What nigelsheldon mentioned above is true.

    You need to add an extra filter on the property : EdiIntAS.IsAS2PayloadMessage == True

    That should work


    Regards, Mazin - MCTS BizTalk Server 2006

    • Proposed as answer by Mazin Alassaf Thursday, February 14, 2013 3:53 PM
    Thursday, February 14, 2013 3:53 PM