locked
How To Rebuild the Camera CETK? RRS feed

  • Question

  • Please move me if I am in the wrong forum, TIA.

    I am having the source to the WinCe 6 of the Camera Cetk (x:\WINCE600\PRIVATE\TEST\MULTIMEDIA\DIRECTX\DSHOW\CAMERA). In there is a camera.mk project make file.

    Do anyone know know how to use it to rebuild the project?

     

    TIA.

    Tuesday, July 13, 2010 6:19 PM

Answers

  • If you want build only the cameraApp,do the following steps,

    * Open release Directory in Build Window from your workspace.
    * Change your directory to
        WINCE600\PRIVATE\TEST\MULTIMEDIA\DIRECTX\DSHOW\COMMON\LIBS
    * Type the command 'build -c'
    * Once it is finished building those directories.
    * Change the directory to
     WINCE600\PRIVATE\TEST\MULTIMEDIA\DIRECTX\DSHOW\CAMERA
    * Type the command 'build -c'
    * It will build those directories,but finish of with the 'kato.lib' non
    availability error.
    * Now Change the directory to
     WINCE600\PRIVATE\TEST\MULTIMEDIA\DIRECTX\DSHOW\CAMERA\CAMERAAPP\
    * Type the command 'build -c'

    Now it will generate the "CameraDshowApp.exe" application binary.

    If you want to build the whole TEST directory means,open the release directory build window and try to run the "\WINCE600\PRIVATE\TEST\buildall.cmd" which will build the whole TEST directory.

    Wednesday, July 14, 2010 4:04 AM

All replies

  • If you want build only the cameraApp,do the following steps,

    * Open release Directory in Build Window from your workspace.
    * Change your directory to
        WINCE600\PRIVATE\TEST\MULTIMEDIA\DIRECTX\DSHOW\COMMON\LIBS
    * Type the command 'build -c'
    * Once it is finished building those directories.
    * Change the directory to
     WINCE600\PRIVATE\TEST\MULTIMEDIA\DIRECTX\DSHOW\CAMERA
    * Type the command 'build -c'
    * It will build those directories,but finish of with the 'kato.lib' non
    availability error.
    * Now Change the directory to
     WINCE600\PRIVATE\TEST\MULTIMEDIA\DIRECTX\DSHOW\CAMERA\CAMERAAPP\
    * Type the command 'build -c'

    Now it will generate the "CameraDshowApp.exe" application binary.

    If you want to build the whole TEST directory means,open the release directory build window and try to run the "\WINCE600\PRIVATE\TEST\buildall.cmd" which will build the whole TEST directory.

    Wednesday, July 14, 2010 4:04 AM
  • Hi Prabu,

    Thank you very very much, I am forever grateful to your helps.

    This kind of information is very difficult to find even with google :)..

    Cheers!

    Wednesday, July 14, 2010 6:31 AM
  • Hi Prabu,

    What is the build window and where do I find it?

    Open release Directory in Build Window from your workspace.

    Linda

    Wednesday, September 1, 2010 3:32 AM
  • Okay I found the build window but this application is not on my machine.  Where do I find it?

     

    DIRECTX\DSHOW\CAMERA\CAMERAAPP

     

    The DSHOW directory does not exist.

     

    thanks,

    Linda

    Wednesday, September 1, 2010 4:35 AM
  • Hi Linda,

    Sorry I haven't been around lately.

    When you install the WinCe600, there is an otpion in the setup to include the source.

    If not, then it would only install the bare minimum.

    Cheers.

    • Proposed as answer by Linda Rawson Wednesday, September 15, 2010 4:01 AM
    Sunday, September 12, 2010 5:56 PM
  • I have reinstalled but it only gives me the repair option.  It seems a shame I could not find this source.

    Linda

    Wednesday, September 15, 2010 2:35 AM
  • I had to install the original CE 6.0 and that was indeed an option for the source code.

     

    Thanks,

    Linda

    Wednesday, September 15, 2010 4:00 AM
  • To install the PRIVATE directory, you have to  select shared source code during the installation of WINCE 6.0
    Vinoth.R http://vinoth-vinothblog.blogspot.com http://www.e-consystems.com
    Wednesday, September 15, 2010 6:51 AM
  • Anyone know how to adapt the codes to compile under Windows Mobile 6.5.3?

    TIA.

    Friday, December 17, 2010 2:49 AM
  • HI,

    When I do 

    Type the command 'build -c' 

    I get some errors:

    BUILD: [Thrd:Sequence:Type  ] Message
    BUILD: [01:0000000036:ERRORE] C:\WINCE600\PRIVATE\TEST\MULTIMEDIA\DIRECTX\DSHOW\COMMON\LIBS\LOGGER\.\filelogger.cpp : fatal error C1033: cannot open program database 'd:\projects\cekn\wince600\smdkv210_armv4i\oak\lib\armv4i\retail\logger.pdb'
    BUILD: [01:0000000040:ERRORE] C:\WINCE600\PRIVATE\TEST\MULTIMEDIA\DIRECTX\DSHOW\COMMON\LIBS\LOGGER\.\networklogger.cpp : fatal error C1033: cannot open program database 'd:\projects\cekn\wince600\smdkv210_armv4i\oak\lib\armv4i\retail\logger.pdb'

    Could you give me any suggestion?

    Thanks

    Yanbin Yue


    gg

    Monday, February 4, 2013 9:05 AM
  • Hello Prabu

    When I run the buildall.cmd, I get some errors as follow;

    BUILD: [01:0000000120:ERRORE] NMAKE :  U1073: don't know how to make 'C:\project
    \wince\Wince600\SMDKV210_ARMV4I\oak\lib\ARMV4I\retail\stressutils.lib'

    Could you give any suggestion?

    Thanks,
    Yanbin Yue


    gg

    Thursday, February 28, 2013 6:49 AM