none
Entity Framework RRS feed

  • Question

  • I have an app that references two dlls.  One is using EF 4.0 and cannot be upgraded and the other is using EF6.0.  Is there a way to handle this in the config?  I have tried this:

    <runtime> <assemblyBinding xmlns="urn:schemas-microsoft-com:asm.v1"> <dependentAssembly> <assemblyIdentity name="EntityFramework" publicKeyToken="b77a5c561934e089" culture="neutral" />

    <codeBase version="6.0.0.0" href="C:\Projects\project\2.1.1EF2\packages\EntityFramework.6.1.0\lib\net45\EntityFramework.dll"/> <codeBase version="4.4.0.0" href="C:\Projects\project\2.1.1EF2\packages\EntityFramework.6.1.0\lib\net45\EntityFramework.dll"/> </dependentAssembly> </assemblyBinding> </runtime>

    It still wants this:

    <section name="entityFramework" type="System.Data.Entity.Internal.ConfigFile.EntityFrameworkSection, EntityFramework, Version=4.4.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089" requirePermission="false" />
    Please let me know if there is a way to do this.  Thanks.

    and it is not workting

    Thursday, July 9, 2015 4:39 PM

Answers