locked
How to display multiple webparts on site's home page RRS feed

  • Question

  • I want to show multiple webparts or Blocks of data on site's home page, which will show carts from different lists and will bring summarized data from different LISTs.

    How may I add multiple webparts side by side ? OR is their any other technique to do this ?

    Thanks in advance.

    Friday, April 15, 2011 1:08 PM

Answers

  • I assume you are working with MOSS 2007. In MOSS 2007, you can make use of existing out of the box page layouts that are already available to create a page. The page you would choose should have webpart zones next to each other. You can make use of Blank web part page.

    • Navigate to Pages library in the site. (Site Actions -> View all site content -> Pages)
    • Click on New -> Select Blank web part page. 
    • Enter the appropriate details such as name and title too. click create
    • Once created, you should see two webpart zones next to each other. 
    • Have your two webparts inserted in those two zones. 
    • Publish the page. 
    • Click on Site Actions -> site settings -> and click on Home Page under look and feel. 
    • Change the page to newly created page.
    • Click ok. 

     

    If for some reason, this layout does not work, you could either choose a different layout or create a custom layout of your own. For creating new page layouts, take a look at this article. 

    http://weblogs.asp.net/jimjackson/archive/2007/11/05/create-a-new-page-layout-in-sharepoint-2007-feature-based.aspx

    Hope this helps. 


    V
    • Edited by Mike Walsh FIN Saturday, April 16, 2011 9:19 AM SP 2010 reference removed. Off-topic
    • Marked as answer by David HM Monday, April 25, 2011 1:37 AM
    Friday, April 15, 2011 2:04 PM

All replies

  • I assume you are working with MOSS 2007. In MOSS 2007, you can make use of existing out of the box page layouts that are already available to create a page. The page you would choose should have webpart zones next to each other. You can make use of Blank web part page.

    • Navigate to Pages library in the site. (Site Actions -> View all site content -> Pages)
    • Click on New -> Select Blank web part page. 
    • Enter the appropriate details such as name and title too. click create
    • Once created, you should see two webpart zones next to each other. 
    • Have your two webparts inserted in those two zones. 
    • Publish the page. 
    • Click on Site Actions -> site settings -> and click on Home Page under look and feel. 
    • Change the page to newly created page.
    • Click ok. 

     

    If for some reason, this layout does not work, you could either choose a different layout or create a custom layout of your own. For creating new page layouts, take a look at this article. 

    http://weblogs.asp.net/jimjackson/archive/2007/11/05/create-a-new-page-layout-in-sharepoint-2007-feature-based.aspx

    Hope this helps. 


    V
    • Edited by Mike Walsh FIN Saturday, April 16, 2011 9:19 AM SP 2010 reference removed. Off-topic
    • Marked as answer by David HM Monday, April 25, 2011 1:37 AM
    Friday, April 15, 2011 2:04 PM
  • You can add webpart by using Sharepoint designer or directly on layout.

    If you want webpart in some particular fashion use SPD.

    If you click edit page from site actions, you will see "Add Web Part" link. Just click that link and the webpart.

    To add more in same zone click that "Add webpart Link again" and add another.


    Dare to promise
    Friday, April 15, 2011 4:00 PM
  • Hi,

    You will need to edit the homepage and not create a new page.
    You will need to make sure that the webpart zones are placed side by side with width setings adjustment (you can do this by using SharePoint Designer (free download)). Then go ahead and add web parts from your selection and ok or publish the page. Alternatively, if you are using MOSS then choose the appropriate Welcome page template.

    hth,


    Chirag Patel, MCTS
    @techChirag
    • Edited by techChirag Saturday, April 16, 2011 8:08 AM typo corrected.
    Saturday, April 16, 2011 8:07 AM