View Backlog link is missing from the TFS11 home page


  • We upgraded from 2010 to TFS11 CTP recently. Went well. We originally saw the View Backlog link and could see our Iterations and New Stories.  In the last couple weeks we made some changes to Group Permissions within TFS and web access. We noticed at some point that the View backlog disappeared. Did I screw something up with permissions?  how do I get the current sprint/iteration to show up on the home page and get the view backlog link back?

    I don't even see a Planning or Project Management menu item any more at the top of the web UI.  Any ideas of things to check is appreciated.



    Thursday, May 31, 2012 9:27 AM


  • I found it this morning.

    My problem was that Web Access Default Level was resetted to "Limited". So I had to reset it to "Full Access" on the main Administration page:

    Saturday, June 02, 2012 6:33 PM

All replies

  • I just installed the TFS 2012 RC as an upgrade from the Beta edition and am now having the same issue. All projects that originally had the Backlog tab no longer do, although the Board tab is still present. If I navigate directly to http://[TFSSERVER]/[COLLECTION/[PROJECT]/_backlogs, I get the following error:

    TF400409: You do not have licensing rights to access this feature: Backlog and Sprint Planning Tools

    Thanks in advance,

    Joseph A. Young

    • Proposed as answer by iCeCLoW Friday, June 01, 2012 10:27 PM
    • Unproposed as answer by iCeCLoW Friday, June 01, 2012 11:20 PM
    Friday, June 01, 2012 1:40 AM
  • Hi Rob and Joseph,

    Please confirm you have view project-level information permission in order to get the view backlog link in the TFS web access page. Also have view work items in this node permission for the root area and iteration.

    Friday, June 01, 2012 8:05 AM
  • Hi Tester 321123,

    I'm set up as both project administrator and project collection administrator with all access rights turned on, and so all rights should automatically bubble down to me. I have access to the task board at least. It looks like the "Request Feedback" link has also disappeared from all projects.

    To fix this, I've also tried to apply the Agile Preview 4 process template to the projects, using the manual update procedures detailed  here: http://msdn.microsoft.com/en-us/library/hh500409(v=vs.110)#download. Didn't work though :(

    Thanks for the help,

    Joseph A. Young

    Friday, June 01, 2012 12:19 PM
  • im also having the same issue, I cannot see the backlog in any of my existing projects.

    There are no links for it, and accesing by the direct url shows the same exact message.

    My users all have the  view project-level information. However I was not able to find that area related permission defined, though I was using the TFS Administrator, Project Collection Administrator and Project Administrator.

    What can I do to see the backlog link again?

    Friday, June 01, 2012 10:27 PM
  • iCeCLoW, you can access the area-related permissions through Visual Studio, by going into the project settings and finding the area settings. In that dialog, there's a security section for both areas and iterations.

    However, I checked both and I have full permissions there, too. It almost seems like RC was released with the wrong license, except that the task board is still visible. I don't know how useful a task board is without the underlying backlog and capacity pages!

    I also created two new test projects from scratch--one with the Agile Preview 4 template, and one with the Scrum 2.0 Preview 4 template. Both gave me exactly the same results--a task board, but no product backlog page or "Request Feedback" links.

    Additionally, in the collaboration section of Team Explorer in VS 2012 RC, the iteration section says something about "You do not have the sprint fully configured for this project." There is a link to the home page and task board from there as well, but nothing to the backlog page.

    That's about all the testing I can think of without trying to reinstall TFS completely. To install it in the first place, I uninstalled the Beta, installed the RC, and then ran the upgrade wizard to convert the data warehouse and collection databases. No errors or warnings appeared during the upgrade process.


    Joseph A. Young

    Saturday, June 02, 2012 12:01 AM
  •  I was readingabout new featueres in Tfs , and found that a new capbility of web access called "Feature Enablement" allows to enable Taskboard, Code Review, functionality without changing the template.

    However I do not lnow where it can found

    Saturday, June 02, 2012 5:16 AM
  • There's supposed to be a box on the main administration webpage for the project. However, that box never appeared for me, so I assume it thought my process template was already up to date and had all the features. I even manually went through the process of applying the latest template features (per the link I posted above) just to make sure, and that didn't restore the Backlog tab, either.
    Saturday, June 02, 2012 3:04 PM
  • I found it this morning.

    My problem was that Web Access Default Level was resetted to "Limited". So I had to reset it to "Full Access" on the main Administration page:

    Saturday, June 02, 2012 6:33 PM
  • That was it! Thanks a bunch, iCeCLoW!
    Saturday, June 02, 2012 7:21 PM
  • Changing the default web access permissions worked for me, too.  Thanks for finding that, iCeCLoW.
    Monday, June 04, 2012 1:16 AM
  • I only get control panel and extensions tabs when in the control panel. I don't see a web access tab anywhere. I am using TFS 2012 express RC - should I have this tab?



    Saturday, July 14, 2012 4:42 PM
  • Hi Andy, did u find out the solution for your missing web access tab?

    I am also having this issue. Will appreciate any help.



    Friday, August 31, 2012 8:23 PM